Zyxel · MPN: GS1920-48V2-GB0101F
£321.99
inc. VAT
Spread the cost with Klarna, Clearpay, PayPal, Float or SnapFrom 3 interest-free payments of £107.33 See options

Credit subject to status. 18+, UK residents only. See each provider for terms.

In stock

FREE delivery

Express £9.99

More payment options Spread the cost up to 4 years

Spread the cost up to 4 years with Snap Finance

Pay £1 deposit · Pay in 4 available · Decision in minutes

Soft check, won't affect your credit score. Representative 29.9% APR. Choose Snap Finance at checkout.

How Snap Finance works

We accept all of these. Choose the one you want at checkout.

  • American Express
  • Apple Pay
  • Google Pay
  • Maestro
  • Mastercard
  • PayPal
  • Shop Pay
  • Visa
  • Express checkout Shop Pay, Apple Pay, Google Pay and PayPal
  • Card Visa, Mastercard, American Express and Maestro
  • Pay later Snap Finance, Klarna, Clearpay, PayPal Pay in 3 and more
Go to checkout with this item

Secure checkout. You can add a discount code or gift card on the next page.

Price drop alert

Zyxel GS1920-48V2 Managed Gigabit Ethernet (10/100/1000) Black
Now £321.99

We'll email you if the price of this item drops in the next 90 days.

Overview

  • Inbuilt 'awareness' of other zyxel units in your network
  • Web GUI interface for centralised management
  • One-click remote factory resets and power cycling
  • No additional software required

Advanced smart managed switching
Minimise wasteful overpowering of devices and help your business save money and time whilst powering more devices with the GS1920 series.
Perfect for SMBs these smart managed switches are rich in L2 features and provide 375Watts over
Ethernet providing reliant and future-proof networking.
Zyxel's One Network (ZON) provides a free and easy-to-use tool to simplify configuration, management and troubleshooting of the switch allowing you to focus on your business priorities.
Zyxel's networking equipement comes with in-built 'awareness' of other Zyxel units in your network allowing for one-click remote factory resets and power cycling through Zyxel Smart Connect.

Intuitive web-based interface
Would you like access to L2 features such as LACP, advanced QoS, VLAN, ACL and multicast IGMP snooping, without learning complex command-line interface(CLI)? You can with the intuitive web-based interface.

Connect more devices with consumption mode
Maximise your 375W of total budget and connect more power-hungry devices. 'Consumption mode' allows for delivery of only the actual power required for more efficiency and better ROI for your business.

Hear the silence with Smart Fan
Silent and reliable switch operation ideal for the office environment, both desktop and rack mounted. The in-built smart fan is designed to automatically adjust speed based on device temperature. Smart Fan will be available on current models with a Firmware upgrade from January 2018 (v4.5).

Plug into the power of the Zyxel ONE network
Easily maintain your network in one FREE platform with the Zyxel One Network (ZON) tool. Instal, configure and discover switches, WLAN and gateways in your network with one-click. ZON Utility is a free of charge tool which has been downloaded by over 15,000 users to date.

Maximum flexibility for your Gig
Futureproof your network for growth with the The GS1920 series. Ideal for SMB deployments in multiple scenarios, the GS1920 series provides up to 28 Gigabit copper ports for 24-port models, and up to 6 Gigabit fiber ports for 48-port models.

Specifications

Management features

MIB supportRFC 1066, RFC 1213, RFC 1157, RFC 1493, RFC 1643, RFC 1757, RFC 2011.2012,2013, RFC 2233, RFC 2358, RFC 2674, RFC 2819,2925, RFC 3621, RFC 4022, RFC 4113, RFC 4292, RFC 4293
System event logYes
ARP inspectionYes
Quality of Service (QoS) supportYes
Switch typeManaged

Ports & interfaces

Fiber optic connectorSFP
SFP module slots quantity2
Combo SFP ports quantity4
Basic switching RJ-45 Ethernet ports typeGigabit Ethernet (10/100/1000)
Basic switching RJ-45 Ethernet ports quantity44
Show all 60 specificationsShow fewer specifications

Network

Virtual LAN featuresPrivate VLAN, Voice VLAN, Protocol-based VLAN, MAC address-based VLAN, Port-based VLAN, IP subnet–based VLAN
VLAN supportYes
Flow control supportYes
Rate limitingYes
Spanning tree protocolYes
Copper ethernet cabling technology100BASE-TX, 1000BASE-T
10G supportNo
Networking standardsIEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z

Optical fiber

Fiber ethernet cabling technology1000BASE-X

Data transmission

Packet buffer memory1.5 MB
Forwarding rate74 Mpps
Switching capacity100 Gbit/s
MAC address table16000 entries

Security

Security algorithms802.1x RADIUS, SNMP, SNMPv3
AuthenticationGuest VLAN, Port-based authentication
Authentication typeIEEE 802.1x, RADIUS
Queue scheduling algorithmsSPQ, WFQ, Weighted Round Robin (WRR)
MAC address filteringYes
Password protectionYes
IP-MAC-Port bindingYes
CPU defenseYes
IGMP snoopingYes
Access Control List (ACL)Yes
DHCP featuresDHCP snooping, DHCP relay, DHCPv6 relay, DHCP client

Multicast features

Multicast supportYes

Design

Electromagnetic compatibilityFCC 15 A, CE A, BSMI EMC
SafetyLVD, BSMI
LED indicatorsYes
Product colourBlack
Rack mountingYes

Performance

Mean time between failures (MTBF)672235 h
Noise level26 dB
Flash memory32 MB
Internal memory256 MB

Power

Power consumption (max)36.9 W
AC input frequency50 - 60 Hz
AC input voltage100 - 240 V

Power over Ethernet (PoE)

Power over Ethernet (PoE)No

Operational conditions

Heat dissipation125.83 BTU/h
Storage relative humidity (H-H)10 - 95%
Operating relative humidity (H-H)10 - 95%
Storage temperature (T-T)-40 - 70 °C
Operating temperature (T-T)0 - 50 °C

Weight & dimensions

Weight2.8 kg
Height44.5 mm
Depth220 mm
Width440 mm

Packaging content

Rack mount kitYes
Cables includedAC

Certificates

CertificationRoHS

Delivery & returns

Delivery

  • FREE standard delivery on orders over £50, otherwise £4.95 (3–5 working days).
  • Express delivery £9.99 (1–3 working days) on selected products, UK mainland.
  • PlayStation and Arozzi products use a 5–7 working-day service.
  • Orders are processed within 24 hours, Monday to Friday excluding bank holidays. All deliveries must be signed for.

Returns

  • Changed your mind? Tell us within 14 days of receiving your item, then return it within a further 14 days, unused and in its original packaging. A minimum £9.99 collection fee applies.
  • Faulty or damaged on arrival? Contact us within 48 hours of delivery.
  • Custom-built PCs can only be returned if faulty. Opened headphones, earphones and AirPods can't be returned for hygiene reasons.

Full delivery information · Full returns policy