Zyxel · MPN: GS190024HPV2-GB0101F
£269.99
inc. VAT
Spread the cost with Klarna, Clearpay, PayPal, Float or SnapFrom 3 interest-free payments of £89.99 See options

Credit subject to status. 18+, UK residents only. See each provider for terms.

In stock

FREE delivery

Express £9.99

More payment options Spread the cost up to 4 years

Spread the cost up to 4 years with Snap Finance

Pay £1 deposit · Pay in 4 available · Decision in minutes

Soft check, won't affect your credit score. Representative 29.9% APR. Choose Snap Finance at checkout.

How Snap Finance works

We accept all of these. Choose the one you want at checkout.

  • American Express
  • Apple Pay
  • Google Pay
  • Maestro
  • Mastercard
  • PayPal
  • Shop Pay
  • Visa
  • Express checkout Shop Pay, Apple Pay, Google Pay and PayPal
  • Card Visa, Mastercard, American Express and Maestro
  • Pay later Snap Finance, Klarna, Clearpay, PayPal Pay in 3 and more
Go to checkout with this item

Secure checkout. You can add a discount code or gift card on the next page.

Price drop alert

Zyxel GS1900-24HP Managed Gigabit Ethernet (10/100/1000) 1U Black
Now £269.99

We'll email you if the price of this item drops in the next 90 days.

Overview

  • Managed SNMP v1,v2,v3, RMON (1,2,3,9)
  • Quality of Service (QoS) support
  • Basic switching RJ-45 Ethernet ports quantity: 24
  • 10BASE-T, 100BASE-T, 1000BASE-T
  • 1U
  • Power supply included

Simple, Fast and Smart Managed Switches for Small Business Connectivity
The ZyXEL GS1900 Series of 8/16/24/48-port GbE Smart Managed Switch with Gigabit speed and essential managing functions bring your business network more fexibility and connectivity. The 1900 Series consists of eight (8) models—the GS1900-8, GS1900-8HP, GS1900-16, GS1900-24E, GS1900-24, GS1900-24HP, GS1900-48 and GS1900-48HP. Providing GbE switches with powersaving functions, fanless design and full IPv6 support ensure your network to be ready for future expansions. In addition, the PoE models GS1900-8HP/24HP/48HP Gigabit switch complies with the IEEE 802.3at Power over Ethernet (PoE) Plus standard.

Versatility and fexibility for different needs
The complete ZyXEL GS1900 Series has an essential portfolio of 8/16/24/48-port compact desktop and rackmount size with GbE connectivity. All models support multiple deployment methods to fulfill the needs for small offices and meeting room environments such as wall-, under table- or desktop-mounting and rackmount options. It’s now quick and effortless to enjoy the high-speed business network applications without a hitch. Additionally, the GS1900-24/24HP/48/48HP is equipped with 2 extra SFP slots to provide 100M and GbE speeds for long-distance deployments.

Simple, intuitive wizard set up
For small businesses that want to manage their infrastructure in advance, the ZyXEL GS1900 Series comes with a friendly built-in Web-based browser for simple configuration and management. Moreover, the friendly step-by-step intuitive wizard helps avoiding multiple complicated configuration pages for quick set up with few clicks in the matter of minutes. To guide the users from start-up, VLAN, Guest VLAN to QoS setting, the ZyXEL Series offers four most common steps and combines them into a quick and easy setup wizard; which does not just save deployment time and efforts, but is also helpful especially for the non-IT staff.

Avoiding network errors with easy management

The ZyXEL GS1900 Series is equipped with advanced management features to make the network stable and secure: loop protection that prevents network flooding, dual images to provide a backup FW if one crashes and storm control to ensure network efficiency, friendly on/off DoS with simple click to enable/disable instead of several setup pages, while SSL ensures the management frames are well encrypted when the device is accessed. The GS1900 Series provides network error prevention features and integrated network security for reduced risk and improved data streaming.

Energy saving for IEEE 802.3az
As operating overheads such as electric bills increase constantly due to the arising green awareness, businesses have to avoid unnecessary energy waste. The built-in IEEE 802.3az Energy Efficient Ethernet (EEE) and more ZyXEL innovative green features of ZyXEL GS1900 Series can reduce energy consumption of Ethernet devices through multiple intelligent ways.

Specifications

Management features

MIB supportRFC 1213 MIB II, RFC 2819, RFC 1215, RFC 1493
Quality of Service (QoS) supportYes
Switch typeManaged

Ports & interfaces

SFP module slots quantity2
Gigabit Ethernet (copper) ports quantity24
Basic switching RJ-45 Ethernet ports typeGigabit Ethernet (10/100/1000)
Basic switching RJ-45 Ethernet ports quantity24
Show all 20 specificationsShow fewer specifications

Network

Flow control supportYes
Rate limitingYes
Broadcast storm controlYes
Copper ethernet cabling technology10BASE-T, 100BASE-T, 1000BASE-T
Networking standardsIEEE 802.1p, IEEE 802.3, IEEE 802.3ab, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x

Security

Security algorithms802.1x RADIUS
MAC address filteringYes
SSH/SSL supportYes

Protocols

Management protocolsSNMP v1,v2,v3, RMON (1,2,3,9)

Design

Product colourBlack
Form factor1U

Power

Power supply includedYes

Certificates

CertificationCE, FCC, C-Tick, Class A (GS1900-8HP/24/24HP/48/48HP)CE, FCC, C-Tick, Class B (GS1900-8/16/24E)BSMI CNS13438

Delivery & returns

Delivery

  • FREE standard delivery on orders over £50, otherwise £4.95 (3–5 working days).
  • Express delivery £9.99 (1–3 working days) on selected products, UK mainland.
  • PlayStation and Arozzi products use a 5–7 working-day service.
  • Orders are processed within 24 hours, Monday to Friday excluding bank holidays. All deliveries must be signed for.

Returns

  • Changed your mind? Tell us within 14 days of receiving your item, then return it within a further 14 days, unused and in its original packaging. A minimum £9.99 collection fee applies.
  • Faulty or damaged on arrival? Contact us within 48 hours of delivery.
  • Custom-built PCs can only be returned if faulty. Opened headphones, earphones and AirPods can't be returned for hygiene reasons.

Full delivery information · Full returns policy