Zyxel GS1900-24E Managed L2 Gigabit Ethernet (10/100/1000) 1U Black
Spread the cost with Klarna, Clearpay, PayPal or FloatFrom 3 interest-free payments of £31.33 See options
Credit subject to status. 18+, UK residents only. See each provider for terms.
Out of stock
FREE delivery
Express £9.99
Couldn't load pickup availability
- 14-day returns Details
- UK manufacturer warranty Details
- Price Match Promise Details
- Rated 4.9/5 by customers on Trustpilot & Feefo Read reviews
Available now
Overview
- Start up button
- VLAN
- QoS
- Link aggregation
Near silent operation
The GS1900 Series includes both fan-less and built-in smart fan models. The smart fan is designed to automatically adjust speed based on device temperature. You can barely hear the sound while the switch is operating. It is ideal for your office environment.
Intelligent PoE+ powers more devices
PoE models (8HP/10HP/24EP/24HPv2/48HPv2) come with default PoE consumption mode which delivers only the actual power required by your networked devices, reserves the rest and optimizes its power budget. That means a single switch can power more APs, IP cameras and VoIP phones, ensuring a better ROI for your business. All of them support the IEEE 802.3at providing a maximum of 30W per port.
Speedy Gigabit performance—built for SMBs
The GS1900 is a series of switches with full non-blocking bandwidth of up to 1 Gbps per port. An ideal upgrade from an unmanaged switch, it’s a great choice for SMBs that want to enjoy high-speed business network applications at full wired non-blocking speed.
Easy and intuitive management
The Smart Managed GS1900 Series switch feature with web-based interface to manage advanced functions such as VLAN, QoS, IGMP Snooping, Link Aggregation (LAG), IPv6 and DoS prevention easily. Also, the user-friendly wizard helps to walk through setup, configuration and even advanced settings quickly.
Specifications
Management features
| MIB support | RFC 1213 MIB II, RFC 2819 RMON (group 1, 2, 3, 9),RFC 1215 generic traps, RFC 1493 bridge, Zyxel private common MIB |
|---|---|
| System event log | Yes |
| Web-based management | Yes |
| Quality of Service (QoS) support | Yes |
| Switch layer | L2 |
| Switch type | Managed |
Ports & interfaces
| Power connector | AC-in jack |
|---|---|
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| Basic switching RJ-45 Ethernet ports quantity | 24 |
Show all 61 specificationsShow fewer specifications
Network
| Virtual LAN features | Stacked VLAN, VLAN mapping |
|---|---|
| VLAN support | Yes |
| Link aggregation | Yes |
| Flow control support | Yes |
| MAC address auto-learning supported | Yes |
| Ethernet LAN data rates | 10,100,1000 Mbit/s |
| Spanning tree protocol | Yes |
| Full duplex | Yes |
| Port mirroring | Yes |
| 10G support | No |
| Networking standards | IEEE 802.1D, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.3, IEEE 802.3ab, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x |
Data transmission
| Packet buffer memory | 0.525 MB |
|---|---|
| Jumbo frames | 9000 |
| Jumbo frames support | Yes |
| Store-and-forward | Yes |
| Forwarding rate | 35.7 Mpps |
| Switching capacity | 48 Gbit/s |
| MAC address table | 8000 entries |
Security
| Security algorithms | 802.1x RADIUS |
|---|---|
| Authentication type | RADIUS, TACACS+ |
| MAC address filtering | Yes |
| Password protection | Yes |
| SSH/SSL support | Yes |
| Static port security | Yes |
| IGMP snooping | Yes |
| DHCP features | DHCP client |
Design
| Wall mountable | Yes |
|---|---|
| LED indicators | Yes |
| Reset button | Yes |
| Product colour | Black |
| Form factor | 1U |
| Stackable | Yes |
| Rack mounting | Yes |
Performance
| Mean time between failures (MTBF) | 804.714 h |
|---|
Power
| Power consumption (max) | 15.1 W |
|---|---|
| AC input frequency | 50 - 60 Hz |
| AC input voltage | 100 - 240 V |
| Power supply included | Yes |
| Power source | AC |
Power over Ethernet (PoE)
| Power over Ethernet (PoE) | No |
|---|
Operational conditions
| Heat dissipation | 51.49 BTU/h |
|---|---|
| Storage relative humidity (H-H) | 10 - 95% |
| Operating relative humidity (H-H) | 10 - 95% |
| Storage temperature (T-T) | -40 - 70 °C |
| Operating temperature (T-T) | 0 - 50 °C |
Weight & dimensions
| Weight | 1.56 kg |
|---|---|
| Height | 42 mm |
| Depth | 162 mm |
| Width | 267 mm |
Packaging content
| Rack mount kit | Yes |
|---|---|
| Cables included | AC |
Certificates
| Certification | EMC■ CE, FCC, C-Tick, Class A(GS1900-24/24EP/24HPv2/48/48HPv2)■ CE, FCC, C-Tick, Class B(GS1900-8/8HP/10HP/16/24E)■ BSMI CNS13438• Safety■ LVD EN60950-1■ BSMI CNS14336-1■ CB IEC60950-1(GS1900-8HP/10HP/16/24E/24)• RoHS compliant |
|---|
Customer reviews
Delivery & returns
Delivery
- FREE standard delivery on orders over £50, otherwise £4.95 (3–5 working days).
- Express delivery £9.99 (1–3 working days) on selected products, UK mainland.
- PlayStation and Arozzi products use a 5–7 working-day service.
- Orders are processed within 24 hours, Monday to Friday excluding bank holidays. All deliveries must be signed for.
Returns
- Changed your mind? Tell us within 14 days of receiving your item, then return it within a further 14 days, unused and in its original packaging. A minimum £9.99 collection fee applies.
- Faulty or damaged on arrival? Contact us within 48 hours of delivery.
- Custom-built PCs can only be returned if faulty. Opened headphones, earphones and AirPods can't be returned for hygiene reasons.