Menu
  • Build your PC in 3D
  • PC Gift Finder
  • Ink Finder
  • Outlet deals

Shop by category

  • Laptops
    • Shop all Laptops
    • Laptops by type
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
      • 2 in 1 Laptops
      • Business Laptops
      • Education Laptops
      • Chromebooks
      • Slim Laptops
      • Refurbished Laptops
    • Popular Searches
      • Laptops under £250
      • Laptops under £500
      • Laptops under £1000
      • 15.6 Inch Laptops
      • 14 Inch Laptops
      • 11.6 Inch Laptops
    • Laptops by brand
      • Microsoft
      • Samsung
      • Apple
      • Lenovo
      • HP
      • ASUS
      • Acer
      • Dell
    • Laptop accessories
      • Bags & Cases
      • Docking Stations
      • Laptop RAM
      • Keyboards
      • Mice
      • Software
      • USB Flash Drives
      • Headsets & Headphones
      • Webcams
      • Privacy Filters
  • PCs
    • Shop all PCs
    • Desktop PCs
      • View All PCs
      • The Gaming Club PCs
      • Gaming PCs
      • Barebone PCs
      • Windows PCs
      • All-In-One PCs
      • iMacs / Mac Minis
    • Custom Build PCs
      • Build a Gaming PC
      • £500 - £999 Gaming PCs
      • £1000 - £1999 Gaming PCs
      • £2000+ Gaming PCs
    • Gaming PCs
      • View All Gaming PCs
    • PC Accessories
      • View all Accessories
      • Storage
      • Keyboards
      • Mice
      • Mouse Mats
      • Headsets
      • Gaming Headsets
      • Webcams
      • Speakers
      • Software
  • Components
    • Components
      • View All Components
    • Graphics Cards
      • View All Graphics Cards
      • NVIDIA Graphics Cards
      • AMD Graphics Cards
      • Intel Graphics Cards
      • NVIDIA 5090 Graphics Cards
      • NVIDIA 5080 Graphics Cards
      • NVIDIA 5070 Graphics Cards
    • Storage
      • View All Storage
      • SSD Drives
      • M.2 SSDs
      • Internal Solid State Drives
      • External Solid State Drives
    • Cooling
      • View All Cooling
      • Liquid Cooling
      • Air Coolers
      • Case Fans
    • Processors
      • View All Processors
      • Intel Processors
      • AMD Processors
    • Memory
      • View All Memory
      • DDR5 RAM
      • DDR4 RAM
      • DDR3 RAM
    • Motherboards
      • View All Motherboards
      • Intel Motherboards
      • AMD Motherboards
    • Power Supplies
      • View All Power Supplies
      • 300W-650W
      • 750W
      • 850W
      • 1000W+
  • Computing
    • Monitors
      • View all Monitors
      • View All Monitors
      • 4K Monitors
      • Gaming Monitors
      • 24" Monitors
      • 27" Monitors
      • 32" Monitors
      • 34" Monitors
      • 35" + Monitors
      • QHD Monitors
      • Ultra Wide Monitors
      • Monitor Mounts & Arms
    • Desktop PCs
      • View All Desktop PCs
      • Gaming PCs
      • Custom Built PCs
      • Apple iMac & Mac Minis
    • Laptops
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
    • Networking
      • View All Networking
      • Whole Home Mesh Wi-Fi
      • Wifi Routers & Modems
      • Network Switches
      • Wireless Access Points
      • Wifi Range Extenders
      • Network Cards
    • Printers & Scanners
      • View All Printers
      • All-In-One Printers
      • Laser Printers
      • Inkjet Printer
      • Label Printers
      • Scanners
    • Ink & Printer Accessories
      • Ink Cartridges
      • Toner Cartridges
      • Paper & Card
      • Shredders
    • Audio
      • Speakers
    • PC Cases
      • View All Cases
      • Full Tower Cases
      • Mid Tower Cases
      • Mini ITX Cases
      • Micro ATX Cases
  • TV & Audio
    • Shop all TV & Audio
    • Televisions
      • View all Televisions
      • View all TVs
      • 55" or more TVs
      • 48" - 54" TVs
      • 42" - 47" TVs
      • 32" - 41" TVs
      • Smaller TVs 32" and Below
      • 4K Ultra HD TVs
    • TV accessories
      • Smart TV Boxes
      • Smart TV Dongles
      • TV stands
      • Remote controls
    • Blu-Ray and Home Cinema
      • Home cinema systems and soundbars
    • Projectors
      • View all Projectors
      • 4K Projectors
      • HD Projectors
    • Speakers & Soundbars
      • View all Speakers
      • Soundbars
      • Portable bluetooth speakers
    • Headphones
      • View all headphones
      • In-ear headphones
      • Over-ear headphones
      • Wired headphones
      • Wireless and bluetooth headphones
      • Sports headphones
  • Gaming
    • Shop all Gaming
    • Gaming PCs and Laptops
      • View all Gaming PCs
      • View all Gaming Laptops
    • Gaming Monitors
      • View all Gaming Monitors
      • 144 HZ + Monitors
      • 4K Monitors
      • Curved Monitors
      • Ultra Wide Monitors
    • Build Your Own Gaming PC
      • Start from Scratch
    • Simulation
      • Flight Simulation
      • Racing Simulation
      • VR Headsets
    • Gaming Accessories
      • View all Gaming Accessories
      • Gaming Chairs
      • Gaming Desks
      • Gaming Keyboards
      • Gaming Mice
      • Gaming Headsets
      • Controllers
      • Gaming Routers
      • Microphones
      • Speakers
      • Streaming
      • Mouse Pads
    • Gaming Components
      • View all Components
      • Graphics Cards
      • Processors
      • Motherboards
      • Memory
      • Cases
      • Cooling
      • Power Supplies
      • Laptop RAM
      • Storage
    • Console Gaming
      • View all Console Gaming
      • Console Storage
      • Xbox Consoles
      • Xbox Controllers
      • Playstation Consoles
      • Playstation Controllers
      • Nintendo Switch Consoles
      • Nintendo Switch Controllers
    • Games
      • PS5 games
      • Xbox games
      • Nintendo Switch games
  • Phones & Tablets
    • Shop all Phones & Tablets
    • Tablets
      • View all Tablets
      • Samsung Tablets
      • Lenovo Tablets
      • Tablet Cases
    • iPads
      • View all iPads
    • Smart Phones
      • View all Smart Phones
      • View all Mobile Phones
      • Mobile Phones (Non-Smart)
      • Apple iPhones
      • Samsung Phones
    • Accessories
      • View all Phone Cases
      • iPhone Cases
      • Samsung Phone Cases
      • Car Chargers
      • Power Banks
      • Mains Chargers
      • Charging Cables
      • Screen Protectors
  • Home & Lifestyle
    • Shop all Home & Lifestyle
    • Smart Home
      • View all Smart Home
      • Video Doorbells
      • Indoor Cameras
      • Outdoor Smart Cameras
      • Smart Lighting
    • Surveillance and Security
      • View all Security Cameras
      • NVR/DVRs
    • Health and Wellbeing
      • View all Health & Wellbeing
      • E-Scooters
      • Smart Watches
      • Activity Trackers
      • Coffee Machines
      • Coffee Grinders
      • Coffee Maker Parts & Accessories
    • Home Office
      • View all Home Office
      • Home Office Desks
      • Home Office Chairs
  • Ink Finder
  • Outlet
  • Sign in
  • Checkout
Back to the Office

Sign in Checkout
  • Laptops
    • Laptops by type
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
      • 2 in 1 Laptops
      • Business Laptops
      • Education Laptops
      • Chromebooks
      • Slim Laptops
      • Refurbished Laptops
    • Popular Searches
      • Laptops under £250
      • Laptops under £500
      • Laptops under £1000
      • 15.6 Inch Laptops
      • 14 Inch Laptops
      • 11.6 Inch Laptops
    • Laptops by brand
      • Microsoft
      • Samsung
      • Apple
      • Lenovo
      • HP
      • ASUS
      • Acer
      • Dell
    • Laptop accessories
      • Bags & Cases
      • Docking Stations
      • Laptop RAM
      • Keyboards
      • Mice
      • Software
      • USB Flash Drives
      • Headsets & Headphones
      • Webcams
      • Privacy Filters
  • PCs
    • Desktop PCs
      • View All PCs
      • The Gaming Club PCs
      • Gaming PCs
      • Barebone PCs
      • Windows PCs
      • All-In-One PCs
      • iMacs / Mac Minis
    • Custom Build PCs
      • Build a Gaming PC
      • £500 - £999 Gaming PCs
      • £1000 - £1999 Gaming PCs
      • £2000+ Gaming PCs
    • Gaming PCs
      • View All Gaming PCs
    • PC Accessories
      • View all Accessories
      • Storage
      • Keyboards
      • Mice
      • Mouse Mats
      • Headsets
      • Gaming Headsets
      • Webcams
      • Speakers
      • Software
  • Components
    • Components
      • View All Components
    • Graphics Cards
      • View All Graphics Cards
      • NVIDIA Graphics Cards
      • AMD Graphics Cards
      • Intel Graphics Cards
      • NVIDIA 5090 Graphics Cards
      • NVIDIA 5080 Graphics Cards
      • NVIDIA 5070 Graphics Cards
    • Storage
      • View All Storage
      • SSD Drives
      • M.2 SSDs
      • Internal Solid State Drives
      • External Solid State Drives
    • Cooling
      • View All Cooling
      • Liquid Cooling
      • Air Coolers
      • Case Fans
    • Processors
      • View All Processors
      • Intel Processors
      • AMD Processors
    • Memory
      • View All Memory
      • DDR5 RAM
      • DDR4 RAM
      • DDR3 RAM
    • Motherboards
      • View All Motherboards
      • Intel Motherboards
      • AMD Motherboards
    • Power Supplies
      • View All Power Supplies
      • 300W-650W
      • 750W
      • 850W
      • 1000W+
  • Computing
    • Monitors
      • View All Monitors
      • 4K Monitors
      • Gaming Monitors
      • 24" Monitors
      • 27" Monitors
      • 32" Monitors
      • 34" Monitors
      • 35" + Monitors
      • QHD Monitors
      • Ultra Wide Monitors
      • Monitor Mounts & Arms
    • Desktop PCs
      • View All Desktop PCs
      • Gaming PCs
      • Custom Built PCs
      • Apple iMac & Mac Minis
    • Laptops
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
    • Networking
      • View All Networking
      • Whole Home Mesh Wi-Fi
      • Wifi Routers & Modems
      • Network Switches
      • Wireless Access Points
      • Wifi Range Extenders
      • Network Cards
    • Printers & Scanners
      • View All Printers
      • All-In-One Printers
      • Laser Printers
      • Inkjet Printer
      • Label Printers
      • Scanners
    • Ink & Printer Accessories
      • Ink Cartridges
      • Toner Cartridges
      • Paper & Card
      • Shredders
    • Audio
      • Speakers
    • PC Cases
      • View All Cases
      • Full Tower Cases
      • Mid Tower Cases
      • Mini ITX Cases
      • Micro ATX Cases
  • TV & Audio
    • Televisions
      • View all TVs
      • 55" or more TVs
      • 48" - 54" TVs
      • 42" - 47" TVs
      • 32" - 41" TVs
      • Smaller TVs 32" and Below
      • 4K Ultra HD TVs
    • TV accessories
      • Smart TV Boxes
      • Smart TV Dongles
      • TV stands
      • Remote controls
    • Blu-Ray and Home Cinema
      • Home cinema systems and soundbars
    • Projectors
      • View all Projectors
      • 4K Projectors
      • HD Projectors
    • Speakers & Soundbars
      • View all Speakers
      • Soundbars
      • Portable bluetooth speakers
    • Headphones
      • View all headphones
      • In-ear headphones
      • Over-ear headphones
      • Wired headphones
      • Wireless and bluetooth headphones
      • Sports headphones
  • Gaming
    • Gaming PCs and Laptops
      • View all Gaming PCs
      • View all Gaming Laptops
    • Gaming Monitors
      • View all Gaming Monitors
      • 144 HZ + Monitors
      • 4K Monitors
      • Curved Monitors
      • Ultra Wide Monitors
    • Build Your Own Gaming PC
      • Start from Scratch
    • Simulation
      • Flight Simulation
      • Racing Simulation
      • VR Headsets
    • Gaming Accessories
      • View all Gaming Accessories
      • Gaming Chairs
      • Gaming Desks
      • Gaming Keyboards
      • Gaming Mice
      • Gaming Headsets
      • Controllers
      • Gaming Routers
      • Microphones
      • Speakers
      • Streaming
      • Mouse Pads
    • Gaming Components
      • View all Components
      • Graphics Cards
      • Processors
      • Motherboards
      • Memory
      • Cases
      • Cooling
      • Power Supplies
      • Laptop RAM
      • Storage
    • Console Gaming
      • View all Console Gaming
      • Console Storage
      • Xbox Consoles
      • Xbox Controllers
      • Playstation Consoles
      • Playstation Controllers
      • Nintendo Switch Consoles
      • Nintendo Switch Controllers
    • Games
      • PS5 games
      • Xbox games
      • Nintendo Switch games
  • Phones & Tablets
    • Tablets
      • View all Tablets
      • Samsung Tablets
      • Lenovo Tablets
      • Tablet Cases
    • iPads
      • View all iPads
    • Smart Phones
      • View all Mobile Phones
      • Mobile Phones (Non-Smart)
      • Apple iPhones
      • Samsung Phones
    • Accessories
      • View all Phone Cases
      • iPhone Cases
      • Samsung Phone Cases
      • Car Chargers
      • Power Banks
      • Mains Chargers
      • Charging Cables
      • Screen Protectors
  • Home & Lifestyle
    • Smart Home
      • View all Smart Home
      • Video Doorbells
      • Indoor Cameras
      • Outdoor Smart Cameras
      • Smart Lighting
    • Surveillance and Security
      • View all Security Cameras
      • NVR/DVRs
    • Health and Wellbeing
      • View all Health & Wellbeing
      • E-Scooters
      • Smart Watches
      • Activity Trackers
      • Coffee Machines
      • Coffee Grinders
      • Coffee Maker Parts & Accessories
    • Home Office
      • View all Home Office
      • Home Office Desks
      • Home Office Chairs
  • Ink Finder
  • Outlet
Home D-Link DSS-200G-28MPP network switch Managed L2 Gigabit
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U - image 2
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U - image 3
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U - image 4
1 / 4
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U - image 2
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U - image 3
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U - image 4
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U - image 2
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U - image 3
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U - image 4

D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey

D-Link · MPN: DSS-200G-28MPP
Sale!
from £535.99
/per
inc. VAT
Spread the cost with Klarna, Clearpay, PayPal, Float or SnapFrom 3 interest-free payments of £178.66 See options

Credit subject to status. 18+, UK residents only. See each provider for terms.

Key specs

  • Internal memory128 MB
  • Weight4.71 kg
All specifications

Out of stock

FREE delivery

Express £9.99

 
 
More payment options Snap Finance Spread the cost up to 4 years
Snap Finance

Spread the cost up to 4 years with Snap Finance

Pay £1 deposit · Pay in 4 available · Decision in minutes

Soft check, won't affect your credit score. Representative 29.9% APR. Choose Snap Finance at checkout.

How Snap Finance works

Credit subject to status. 18+, UK residents only. Back to the Office is an Introducer Appointed Representative of Snap Finance Limited, which is authorised and regulated by the Financial Conduct Authority (FRN 741813). Snap Finance Limited is the lender.

We accept all of these. Choose the one you want at checkout.

  • American Express
  • Apple Pay
  • Google Pay
  • Maestro
  • Mastercard
  • PayPal
  • Shop Pay
  • Visa
  • Express checkout Shop Pay, Apple Pay, Google Pay and PayPal
  • Card Visa, Mastercard, American Express and Maestro
  • Pay later Snap Finance, Klarna, Clearpay, PayPal Pay in 3 and more
Go to checkout with this item

Secure checkout. You can add a discount code or gift card on the next page.

  • 14-day returns Details
  • UK manufacturer warranty Details
  • Price Match Promise Details
  • Rated 4.9/5 by customers on Trustpilot & Feefo Read reviews

Available now

    OverviewSpecificationsReviews Delivery & returns

    Overview

    • High PoE budgets and support for IEEE 802.3bt 90 W PoE
    • 6 kV surge protection on all PoE ports
    • Alarm Port and four-stage PoE usage indicator light
    • Smart Fan design
    • Surveillance traffic optimization
    • Auto-detect ONVIF devices
    • Built-in SNMP MIB
    • Surveillance VLAN
    • Easy deployment with automatic configuration

    Enjoy the Power of Next-Gen Surveillance Switch
    Enhance your surveillance environment with the DSS-200G, a smart and easily installed device that delivers greater control and flexibility. Discover the capabilities of this intelligent tool that automates processes and adds intelligence to your network.

    Built for Surveillance,
    with Gigabit Ethernet & PoE++

    Designed to meet surveillance requirements for businesses of all sizes, with features like support for high-powered PTZ cameras, high PoE budgets, Auto Surveillance VLAN, and surge protection, these switches are ideal for IP surveillance setups.

    Long Range PoE Delivery
    Connect and power cameras up to 250 metres away without the need for additional PoE extenders.

    Power Your Devices
    Supports PoE/PoE+ to connect and power your PoE-cable network devices via Ethernet cables without the need for power adapters.

    Reliable PoE Connections
    Surge protection on all PoE ports protects the switch when feeding power to PoE-capable devices.

    Rapid deployments with a single PoE cable.
    The series supports PoE, and some provide higher power PoE++, delivering up to 90 watts on selected ports, enabling faster deployment of PoE devices such as IP cameras, VoIP phones, access points, terminals, speakers, lights, conferencing systems, displays, and more.

    Reach further with a flick of a switch.
    The built-in DIP switch allows easy configuration and quick adjustment of application settings without the need to access the web configuration. Quickly enable and disable functions such as QoS, Extend (connection by up to 250 metres), Port Isolation, PD-Alive and STP (Spanning Tree Protocol) in an instant.

    Protects the network against power surges.
    6kV surge protection on all PoE ports protects the network against voltage spikes with link aggregation, ERPS and STP support to make your network more robust and resilient.

    Connect to more with PoE++
    See your remaining power availability with the built-in PoE Power Budget LEDs for 25%, 50%, 75%, and 100% power usage at a glance. And utilise up to 518W, with 90W on 8 ports and 30W on 15 ports for DSS-200G-28MPP, so you can rapidly deploy more devices.

    Layer 2 management features.
    Comes with a complete line-up of L2 features, including port mirroring, Spanning Tree Protocol (STP), and Link Aggregation Control Protocol (LACP). Network maintenance features such as loopback detection and cable diagnostics.

    Quality of Service and bandwidth control.
    Bandwidth control allows network administrators to reserve bandwidth for important functions that require higher priority or more bandwidth.

    Auto Surveillance VLAN consolidates data and surveillance video transmission through a single switch, sparing businesses the expense of dedicated hardware and facilities.

    Voice VLAN enhances the VoIP service by automatically placing voice traffic from IP phones to a designated VLAN. With a prioritised and segmented VLAN, this feature guarantees quality and security of VoIP traffic.

    Energy efficient
    With built-in D-Link Green technology, this series saves power without sacrificing operational performance or functionality.

    Time-Based PoE
    Schedule the ports on the switch to provide PoE power to devices on specific days and during set hours of the week for energy savings

    Sleep mode
    Link status drastically reduces power consumption by automatically putting ports without a link into a sleep mode

    Advanced chipset
    The series incorporates a special chipset with advanced silicon technology for efficient use of energy

    We're here to help.
    Over 35 years in the networking industry

    Innovative end-to-end solution experts for small businesses to large corporations around the world.

    Talking to us is easy
    Skilled local support in 16 countries. Our support teams are ready to help you.

    Specifications

    Management features

    MIB support• RFC768 UDP • RFC791 IP • RFC792 ICMP • RFC793 TCP • RFC826 ARP • RFC1213 MIB II • RFC1493 Bridage MIB • RFC1907 SNMPv2 MIB • RFC1215 MIB Traps Convention • RFC2233 Interface Group MIB • RFC2665 Ether-like MIB • RFC4363 IEEE 802.1p MIB • ZoneDefense MIB • Private MIB • RFC951 BootP client • RFC1542 BootP/DHCP client • RFC2236 IGMP Snooping
    Traffic classificationYes
    Web-based managementYes
    Quality of Service (QoS) supportYes
    Switch layerL2
    Switch typeManaged

    Ports & interfaces

    Combo SFP ports quantity4
    Basic switching RJ-45 Ethernet ports typeGigabit Ethernet (10/100/1000)
    Basic switching RJ-45 Ethernet ports quantity24
    Show all 71 specificationsShow fewer specifications

    Network

    Number of VLANs4094
    Virtual LAN featuresVoice VLAN
    VLAN supportYes
    Link aggregationYes
    Flow control supportYes
    Auto MDI/MDI-XYes
    Auto-negotiationYes
    Rate limitingYes
    Broadcast storm controlYes
    Ethernet LAN data rates1000 Mbit/s
    Spanning tree protocolYes
    Head-of-line (HOL) blockingYes
    Half duplexYes
    Full duplexYes
    Port mirroringYes
    Networking standardsIEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3bt, IEEE 802.3u, IEEE 802.3x

    Data transmission

    Packet buffer memory4.1 MB
    Jumbo frames10240
    Jumbo frames supportYes
    Number of queues4
    Forwarding rate41.67 Mpps
    Switching capacity56 Gbit/s
    MAC address table8000 entries

    Security

    Queue scheduling algorithmsStrict Priority Queue (SPQ), Weighted Round Robin (WRR)
    Password protectionYes
    SSH/SSL supportYes
    IGMP snoopingYes

    Multicast features

    Multicast featuresControllable multicast
    Multicast supportYes

    Design

    Number of fans2 fan(s)
    LED indicatorsActivity, Alarm, Link, Power, Speed
    Reset buttonYes
    Product colourGrey
    Form factor1U

    Performance

    Mean time between failures (MTBF)289075 h
    FanlessNo
    Noise level54 dB
    Flash memory32 MB
    Internal memory128 MB
    Memory typeDDR3-SDRAM

    Power

    Power consumption (max)579.3 W
    Input voltage100 - 240 V
    Input current6.4 A
    AC input frequency50/60 Hz
    AC input voltage100 - 240 V
    Power supply includedYes
    Power sourceAC

    Power over Ethernet (PoE)

    Total Power over Ethernet (PoE) budget518 W
    Power over Ethernet (PoE) power per port30 W
    Power over Ethernet (PoE) ports quantity24
    Power over Ethernet (PoE)Yes

    Operational conditions

    Heat dissipation209.16 BTU/h
    Storage relative humidity (H-H)0 - 95%
    Operating relative humidity (H-H)0 - 95%
    Storage temperature (T-T)-40 - 70 °C
    Operating temperature (T-T)-5 - 50 °C

    Weight & dimensions

    Weight4.71 kg
    Height44 mm
    Depth330 mm
    Width440 mm

    Sustainability

    Sustainability complianceYes

    Certificates

    Compliance certificatesBSMI, CB, CE, Federal Communications Commission (FCC), Low Voltage Directive (LVD), UL, cUL

    Customer reviews

    Delivery & returns

    Delivery

    • FREE standard delivery on orders over £50, otherwise £4.95 (3–5 working days).
    • Express delivery £9.99 (1–3 working days) on selected products, UK mainland.
    • PlayStation and Arozzi products use a 5–7 working-day service.
    • Orders are processed within 24 hours, Monday to Friday excluding bank holidays. All deliveries must be signed for.

    Returns

    • Changed your mind? Tell us within 14 days of receiving your item, then return it within a further 14 days, unused and in its original packaging. A minimum £9.99 collection fee applies.
    • Faulty or damaged on arrival? Contact us within 48 hours of delivery.
    • Custom-built PCs can only be returned if faulty. Opened headphones, earphones and AirPods can't be returned for hygiene reasons.

    Full delivery information · Full returns policy

    Similar products

    Goes with this

    D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey £535.99

    Information

    • About us
    • Contact us
    • Our Reviews
    • Shipping Policy
    • Terms & Conditions
    • Privacy & Cookie Policy
    • Fraud Prevention & Security
    • Returns & Refunds
    • Money Wellness (Debt Advice)
    • For Business

    Support

    • Delivery Information
    • Manufacturer Warranty
    • Price Match Promise
    • Snap Finance
    • Klarna
    • ClearPay
    • Careers
    • Complaints
    • Vulnerable Customer Policy & TCF
    • Ink & Toner Finder
    • Buying Guides
    • Gaming PC Gift Finder
    • Gaming PC Guide for Parents

    My Account

    • Sign In
    • Register
    • Track your order
    • Returns
    • Shop By Brand
    • Affiliate Program
    • FAQ

    Contact Us

    Head Office:
    71-75 Shelton Street, Covent Garden, London, United Kingdom, WC2H 9JQ

    Email: hello@backtotheoffice.co.uk

    Track your order

    Follow Us:

    Opens external website in a new window. Opens external website in a new window. Opens external website in a new window.
    Visa Mastercard American Express PayPal Clearpay
    Klarna Google Pay Apple Pay Snap Finance Float

    Snap Finance: Back to the Office is an Introducer Appointed Representative of Snap Finance Limited which is authorised and regulated by the Financial Conduct Authority (Firm reference number 741813). Snap Finance Limited act as the lender.

    Pay later with Klarna. Borrowing more than you can afford or paying late may negatively impact your financial status and ability to obtain credit. Subject to status. Ts&Cs and late fees apply. Klarna.com/uk/terms-and-conditions

    Clearpay: Clearpay credit subject to status. Ensure you can make repayments on time. You must be 18+ and a permanent UK resident (excl Channel Islands). Clearpay charges a £6 late fee for each late instalment and a further £6 if it’s still unpaid 7 days later. Late fees are capped at £6 for orders under £24 and the lower of £24 or 25% of the order value for orders over £24. Missed payments may affect your future access to credit and your details may be passed onto a debt collection agency working on Clearpay's behalf. T&Cs apply Clearpay.co.uk/terms

    Float: Float charges no interest or fees on your instalment plan. Your credit card issuer’s standard terms and conditions, including interest on outstanding balances, will still apply. Please make sure you can comfortably afford each monthly instalment. Float is the trading name of Float Technologies Limited, registered in England and Wales (Company Number: 16558482). Float is not authorised and regulated by the Financial Conduct Authority.

    © 2026 Back to the Office.

    Your basket

      Your basket is empty

      Start shopping

        Subtotal

        Delivery and any discount codes are calculated at checkout.

        Checkout securely
        View basket