Menu
  • Build your PC in 3D
  • PC Gift Finder
  • Ink Finder
  • Outlet deals

Shop by category

  • Laptops
    • Shop all Laptops
    • Laptops by type
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
      • 2 in 1 Laptops
      • Business Laptops
      • Education Laptops
      • Chromebooks
      • Slim Laptops
      • Refurbished Laptops
    • Popular Searches
      • Laptops under £250
      • Laptops under £500
      • Laptops under £1000
      • 15.6 Inch Laptops
      • 14 Inch Laptops
      • 11.6 Inch Laptops
    • Laptops by brand
      • Microsoft
      • Samsung
      • Apple
      • Lenovo
      • HP
      • ASUS
      • Acer
      • Dell
    • Laptop accessories
      • Bags & Cases
      • Docking Stations
      • Laptop RAM
      • Keyboards
      • Mice
      • Software
      • USB Flash Drives
      • Headsets & Headphones
      • Webcams
      • Privacy Filters
  • PCs
    • Shop all PCs
    • Desktop PCs
      • View All PCs
      • The Gaming Club PCs
      • Gaming PCs
      • Barebone PCs
      • Windows PCs
      • All-In-One PCs
      • iMacs / Mac Minis
    • Custom Build PCs
      • Build a Gaming PC
      • £500 - £999 Gaming PCs
      • £1000 - £1999 Gaming PCs
      • £2000+ Gaming PCs
    • Gaming PCs
      • View All Gaming PCs
    • PC Accessories
      • View all Accessories
      • Storage
      • Keyboards
      • Mice
      • Mouse Mats
      • Headsets
      • Gaming Headsets
      • Webcams
      • Speakers
      • Software
  • Components
    • Components
      • View All Components
    • Graphics Cards
      • View All Graphics Cards
      • NVIDIA Graphics Cards
      • AMD Graphics Cards
      • Intel Graphics Cards
      • NVIDIA 5090 Graphics Cards
      • NVIDIA 5080 Graphics Cards
      • NVIDIA 5070 Graphics Cards
    • Storage
      • View All Storage
      • SSD Drives
      • M.2 SSDs
      • Internal Solid State Drives
      • External Solid State Drives
    • Cooling
      • View All Cooling
      • Liquid Cooling
      • Air Coolers
      • Case Fans
    • Processors
      • View All Processors
      • Intel Processors
      • AMD Processors
    • Memory
      • View All Memory
      • DDR5 RAM
      • DDR4 RAM
      • DDR3 RAM
    • Motherboards
      • View All Motherboards
      • Intel Motherboards
      • AMD Motherboards
    • Power Supplies
      • View All Power Supplies
      • 300W-650W
      • 750W
      • 850W
      • 1000W+
  • Computing
    • Monitors
      • View all Monitors
      • View All Monitors
      • 4K Monitors
      • Gaming Monitors
      • 24" Monitors
      • 27" Monitors
      • 32" Monitors
      • 34" Monitors
      • 35" + Monitors
      • QHD Monitors
      • Ultra Wide Monitors
      • Monitor Mounts & Arms
    • Desktop PCs
      • View All Desktop PCs
      • Gaming PCs
      • Custom Built PCs
      • Apple iMac & Mac Minis
    • Laptops
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
    • Networking
      • View All Networking
      • Whole Home Mesh Wi-Fi
      • Wifi Routers & Modems
      • Network Switches
      • Wireless Access Points
      • Wifi Range Extenders
      • Network Cards
    • Printers & Scanners
      • View All Printers
      • All-In-One Printers
      • Laser Printers
      • Inkjet Printer
      • Label Printers
      • Scanners
    • Ink & Printer Accessories
      • Ink Cartridges
      • Toner Cartridges
      • Paper & Card
      • Shredders
    • Audio
      • Speakers
    • PC Cases
      • View All Cases
      • Full Tower Cases
      • Mid Tower Cases
      • Mini ITX Cases
      • Micro ATX Cases
  • TV & Audio
    • Shop all TV & Audio
    • Televisions
      • View all Televisions
      • View all TVs
      • 55" or more TVs
      • 48" - 54" TVs
      • 42" - 47" TVs
      • 32" - 41" TVs
      • Smaller TVs 32" and Below
      • 4K Ultra HD TVs
    • TV accessories
      • Smart TV Boxes
      • Smart TV Dongles
      • TV stands
      • Remote controls
    • Blu-Ray and Home Cinema
      • Home cinema systems and soundbars
    • Projectors
      • View all Projectors
      • 4K Projectors
      • HD Projectors
    • Speakers & Soundbars
      • View all Speakers
      • Soundbars
      • Portable bluetooth speakers
    • Headphones
      • View all headphones
      • In-ear headphones
      • Over-ear headphones
      • Wired headphones
      • Wireless and bluetooth headphones
      • Sports headphones
  • Gaming
    • Shop all Gaming
    • Gaming PCs and Laptops
      • View all Gaming PCs
      • View all Gaming Laptops
    • Gaming Monitors
      • View all Gaming Monitors
      • 144 HZ + Monitors
      • 4K Monitors
      • Curved Monitors
      • Ultra Wide Monitors
    • Build Your Own Gaming PC
      • Start from Scratch
    • Simulation
      • Flight Simulation
      • Racing Simulation
      • VR Headsets
    • Gaming Accessories
      • View all Gaming Accessories
      • Gaming Chairs
      • Gaming Desks
      • Gaming Keyboards
      • Gaming Mice
      • Gaming Headsets
      • Controllers
      • Gaming Routers
      • Microphones
      • Speakers
      • Streaming
      • Mouse Pads
    • Gaming Components
      • View all Components
      • Graphics Cards
      • Processors
      • Motherboards
      • Memory
      • Cases
      • Cooling
      • Power Supplies
      • Laptop RAM
      • Storage
    • Console Gaming
      • View all Console Gaming
      • Console Storage
      • Xbox Consoles
      • Xbox Controllers
      • Playstation Consoles
      • Playstation Controllers
      • Nintendo Switch Consoles
      • Nintendo Switch Controllers
    • Games
      • PS5 games
      • Xbox games
      • Nintendo Switch games
  • Phones & Tablets
    • Shop all Phones & Tablets
    • Tablets
      • View all Tablets
      • Samsung Tablets
      • Lenovo Tablets
      • Tablet Cases
    • iPads
      • View all iPads
    • Smart Phones
      • View all Smart Phones
      • View all Mobile Phones
      • Mobile Phones (Non-Smart)
      • Apple iPhones
      • Samsung Phones
    • Accessories
      • View all Phone Cases
      • iPhone Cases
      • Samsung Phone Cases
      • Car Chargers
      • Power Banks
      • Mains Chargers
      • Charging Cables
      • Screen Protectors
  • Home & Lifestyle
    • Shop all Home & Lifestyle
    • Smart Home
      • View all Smart Home
      • Video Doorbells
      • Indoor Cameras
      • Outdoor Smart Cameras
      • Smart Lighting
    • Surveillance and Security
      • View all Security Cameras
      • NVR/DVRs
    • Health and Wellbeing
      • View all Health & Wellbeing
      • E-Scooters
      • Smart Watches
      • Activity Trackers
      • Coffee Machines
      • Coffee Grinders
      • Coffee Maker Parts & Accessories
    • Home Office
      • View all Home Office
      • Home Office Desks
      • Home Office Chairs
  • Ink Finder
  • Outlet
  • Sign in
  • Checkout
Back to the Office

Sign in Checkout
  • Laptops
    • Laptops by type
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
      • 2 in 1 Laptops
      • Business Laptops
      • Education Laptops
      • Chromebooks
      • Slim Laptops
      • Refurbished Laptops
    • Popular Searches
      • Laptops under £250
      • Laptops under £500
      • Laptops under £1000
      • 15.6 Inch Laptops
      • 14 Inch Laptops
      • 11.6 Inch Laptops
    • Laptops by brand
      • Microsoft
      • Samsung
      • Apple
      • Lenovo
      • HP
      • ASUS
      • Acer
      • Dell
    • Laptop accessories
      • Bags & Cases
      • Docking Stations
      • Laptop RAM
      • Keyboards
      • Mice
      • Software
      • USB Flash Drives
      • Headsets & Headphones
      • Webcams
      • Privacy Filters
  • PCs
    • Desktop PCs
      • View All PCs
      • The Gaming Club PCs
      • Gaming PCs
      • Barebone PCs
      • Windows PCs
      • All-In-One PCs
      • iMacs / Mac Minis
    • Custom Build PCs
      • Build a Gaming PC
      • £500 - £999 Gaming PCs
      • £1000 - £1999 Gaming PCs
      • £2000+ Gaming PCs
    • Gaming PCs
      • View All Gaming PCs
    • PC Accessories
      • View all Accessories
      • Storage
      • Keyboards
      • Mice
      • Mouse Mats
      • Headsets
      • Gaming Headsets
      • Webcams
      • Speakers
      • Software
  • Components
    • Components
      • View All Components
    • Graphics Cards
      • View All Graphics Cards
      • NVIDIA Graphics Cards
      • AMD Graphics Cards
      • Intel Graphics Cards
      • NVIDIA 5090 Graphics Cards
      • NVIDIA 5080 Graphics Cards
      • NVIDIA 5070 Graphics Cards
    • Storage
      • View All Storage
      • SSD Drives
      • M.2 SSDs
      • Internal Solid State Drives
      • External Solid State Drives
    • Cooling
      • View All Cooling
      • Liquid Cooling
      • Air Coolers
      • Case Fans
    • Processors
      • View All Processors
      • Intel Processors
      • AMD Processors
    • Memory
      • View All Memory
      • DDR5 RAM
      • DDR4 RAM
      • DDR3 RAM
    • Motherboards
      • View All Motherboards
      • Intel Motherboards
      • AMD Motherboards
    • Power Supplies
      • View All Power Supplies
      • 300W-650W
      • 750W
      • 850W
      • 1000W+
  • Computing
    • Monitors
      • View All Monitors
      • 4K Monitors
      • Gaming Monitors
      • 24" Monitors
      • 27" Monitors
      • 32" Monitors
      • 34" Monitors
      • 35" + Monitors
      • QHD Monitors
      • Ultra Wide Monitors
      • Monitor Mounts & Arms
    • Desktop PCs
      • View All Desktop PCs
      • Gaming PCs
      • Custom Built PCs
      • Apple iMac & Mac Minis
    • Laptops
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
    • Networking
      • View All Networking
      • Whole Home Mesh Wi-Fi
      • Wifi Routers & Modems
      • Network Switches
      • Wireless Access Points
      • Wifi Range Extenders
      • Network Cards
    • Printers & Scanners
      • View All Printers
      • All-In-One Printers
      • Laser Printers
      • Inkjet Printer
      • Label Printers
      • Scanners
    • Ink & Printer Accessories
      • Ink Cartridges
      • Toner Cartridges
      • Paper & Card
      • Shredders
    • Audio
      • Speakers
    • PC Cases
      • View All Cases
      • Full Tower Cases
      • Mid Tower Cases
      • Mini ITX Cases
      • Micro ATX Cases
  • TV & Audio
    • Televisions
      • View all TVs
      • 55" or more TVs
      • 48" - 54" TVs
      • 42" - 47" TVs
      • 32" - 41" TVs
      • Smaller TVs 32" and Below
      • 4K Ultra HD TVs
    • TV accessories
      • Smart TV Boxes
      • Smart TV Dongles
      • TV stands
      • Remote controls
    • Blu-Ray and Home Cinema
      • Home cinema systems and soundbars
    • Projectors
      • View all Projectors
      • 4K Projectors
      • HD Projectors
    • Speakers & Soundbars
      • View all Speakers
      • Soundbars
      • Portable bluetooth speakers
    • Headphones
      • View all headphones
      • In-ear headphones
      • Over-ear headphones
      • Wired headphones
      • Wireless and bluetooth headphones
      • Sports headphones
  • Gaming
    • Gaming PCs and Laptops
      • View all Gaming PCs
      • View all Gaming Laptops
    • Gaming Monitors
      • View all Gaming Monitors
      • 144 HZ + Monitors
      • 4K Monitors
      • Curved Monitors
      • Ultra Wide Monitors
    • Build Your Own Gaming PC
      • Start from Scratch
    • Simulation
      • Flight Simulation
      • Racing Simulation
      • VR Headsets
    • Gaming Accessories
      • View all Gaming Accessories
      • Gaming Chairs
      • Gaming Desks
      • Gaming Keyboards
      • Gaming Mice
      • Gaming Headsets
      • Controllers
      • Gaming Routers
      • Microphones
      • Speakers
      • Streaming
      • Mouse Pads
    • Gaming Components
      • View all Components
      • Graphics Cards
      • Processors
      • Motherboards
      • Memory
      • Cases
      • Cooling
      • Power Supplies
      • Laptop RAM
      • Storage
    • Console Gaming
      • View all Console Gaming
      • Console Storage
      • Xbox Consoles
      • Xbox Controllers
      • Playstation Consoles
      • Playstation Controllers
      • Nintendo Switch Consoles
      • Nintendo Switch Controllers
    • Games
      • PS5 games
      • Xbox games
      • Nintendo Switch games
  • Phones & Tablets
    • Tablets
      • View all Tablets
      • Samsung Tablets
      • Lenovo Tablets
      • Tablet Cases
    • iPads
      • View all iPads
    • Smart Phones
      • View all Mobile Phones
      • Mobile Phones (Non-Smart)
      • Apple iPhones
      • Samsung Phones
    • Accessories
      • View all Phone Cases
      • iPhone Cases
      • Samsung Phone Cases
      • Car Chargers
      • Power Banks
      • Mains Chargers
      • Charging Cables
      • Screen Protectors
  • Home & Lifestyle
    • Smart Home
      • View all Smart Home
      • Video Doorbells
      • Indoor Cameras
      • Outdoor Smart Cameras
      • Smart Lighting
    • Surveillance and Security
      • View all Security Cameras
      • NVR/DVRs
    • Health and Wellbeing
      • View all Health & Wellbeing
      • E-Scooters
      • Smart Watches
      • Activity Trackers
      • Coffee Machines
      • Coffee Grinders
      • Coffee Maker Parts & Accessories
    • Home Office
      • View all Home Office
      • Home Office Desks
      • Home Office Chairs
  • Ink Finder
  • Outlet
Home D-Link 28-Port Gigabit PoE+ Smart Managed Switch including 4
D-Link 28-Port Gigabit PoE+ Smart Managed Switch including 4 x 100/1000Mbps Combo Ports
D-Link 28-Port Gigabit PoE+ Smart Managed Switch including 4 x 100/1000Mbps Combo Ports
D-Link 28-Port Gigabit PoE+ Smart Managed Switch including 4 x 100/1000Mbps Combo Ports

D-Link 28-Port Gigabit PoE+ Smart Managed Switch including 4 x 100/1000Mbps Combo Ports

D-Link · MPN: DGS-1210-28MP
Sale!
from £309.99
/per
inc. VAT
Spread the cost with Klarna, Clearpay, PayPal, Float or SnapFrom 3 interest-free payments of £103.33 See options

Credit subject to status. 18+, UK residents only. See each provider for terms.

In stock

FREE delivery

Express £9.99

 
 
More payment options Snap Finance Spread the cost up to 4 years
Snap Finance

Spread the cost up to 4 years with Snap Finance

Pay £1 deposit · Pay in 4 available · Decision in minutes

Soft check, won't affect your credit score. Representative 29.9% APR. Choose Snap Finance at checkout.

How Snap Finance works

Credit subject to status. 18+, UK residents only. Back to the Office is an Introducer Appointed Representative of Snap Finance Limited, which is authorised and regulated by the Financial Conduct Authority (FRN 741813). Snap Finance Limited is the lender.

We accept all of these. Choose the one you want at checkout.

  • American Express
  • Apple Pay
  • Google Pay
  • Maestro
  • Mastercard
  • PayPal
  • Shop Pay
  • Visa
  • Express checkout Shop Pay, Apple Pay, Google Pay and PayPal
  • Card Visa, Mastercard, American Express and Maestro
  • Pay later Snap Finance, Klarna, Clearpay, PayPal Pay in 3 and more
Go to checkout with this item

Secure checkout. You can add a discount code or gift card on the next page.

Price drop alert

D-Link 28-Port Gigabit PoE+ Smart Managed Switch including 4 x 100/1000Mbps Combo Ports
Now £309.99

We'll email you if the price of this item drops in the next 90 days.

By setting an alert you agree to receive price drop emails from Back to the Office for this item and others you view. No newsletters. Unsubscribe at any time. Privacy policy

Alert set

We'll email if the price of D-Link 28-Port Gigabit PoE+ Smart Managed Switch including 4 x 100/1000Mbps Combo Ports drops.

  • 14-day returns Details
  • UK manufacturer warranty Details
  • Price Match Promise Details
  • Rated 4.9/5 by customers on Trustpilot & Feefo Read reviews
OverviewSpecificationsManuals & downloadsReviews Delivery & returns

Overview

  • Managed L2 Web-based management
  • Quality of Service (QoS) support
  • Basic switching RJ-45 Ethernet ports quantity: 24 Console port: RJ-45
  • 10BASE-T, 100BASE-TX, 100BASE-T, 1000BASE-T
  • MAC address table: 16000 entries Switching capacity: 56 Gbit/s
  • 256 Access Control List (ACL)
  • 1U Rack mounting
  • Power over Ethernet (PoE)

The DGS-1210 Series Gigabit Smart Managed Switches is the latest generation of D-Link Smart Managed Switches featuring D-Link Green 3.0 technology. The series offers a high level of energy saving and efficiency, as it also complies with the IEEE 802.3az Energy Efficient Ethernet standard. Support for IPv6 management and configurations ensures your network remains protected after the upgrade from IPv4 to IPv6. By offering multiple management options, the Smart Managed Switches allows quick deployment, infrastructure expansion, and seamless function upgrades. Built for small and medium-sized businesses, the DGS-1210 Series Smart Managed Switches provide functionality, security, and manageability for a fraction of the standard cost of ownership.

The DGS-1210 Series Gigabit Smart Managed Switches includes a range of affordable PoE-enable switches for businesses looking to power VoIP phones, wireless access points or network cameras. The DGS-1210-08P is a 8-port Smart Managed PoE Switch that provides 8 PoE-enabled ports that can supply power of up to 15.4 W each. Whereas the DGS-1210-24P is a 24-port Smart Managed PoE Switch that provides 12 PoE-enabled ports that can support up to 30 W of power output following IEEE 802.3at standard. The design allows more flexibility in power allocation for a variety of powered devices with affordable installation costs.

Easy Management

The D-Link DGS-1210 Series is designed for easy management. All configurations can be made through a Web interface regardless of the host PC’s operating system. Furthermore, the web UI contains ten language options to make operations more straightforward. During the first installation, the D-Link Network Assistant will automatically discover all D-Link Smart Managed Switches in the network, allowing administrators to assign IP addresses and the subnet mask quickly. It also allows simultaneous firmware upgrades to multiple switches, saving a great deal of time. The D-Link Network Assistant1’s important management commands, such as downloading firmware or a configuration file, offer a sophisticated method of batch operations for multiple switches.

Energy Saving

DGS-1210 Series are capable of conserving power without sacrificing operational performance or functionality by using D-Link Green 3.0 technology. Using the Energy Efficient Ethernet standard, the network will automatically decrease the power usage when traffic is low with no setup required. For environments not fully supporting the standard, DGS-1210 switches offer advanced power-saving settings including port shutoff and standby, LED shutoff, and system hibernation based on custom scheduling profiles. The profiles can also be applied to the PoE switch so that there is no unnecessary power consumption during off hours. The DGS-1210 Series switches can also detect the length of connected cables to automatically reduce power usage on shorter cable connections.

Auto Surveillance VLAN and Voice VLAN

The process of setting up IP surveillance and VoIP on a network is automated and cannot be easier. Auto Surveillance VLAN (ASV) consolidates data and surveillance video transmission through the network, sparing businesses the expense of maintaining dedicated facilities. ASV also protects the quality of real-time video by grouping IP surveillance devices on a single high priority VLAN. This ensures that surveillance video streams will not be affected when ordinary data traffic is at their highest levels. Similarly, the Auto Voice VLAN guarantees clear audio quality and efficient transmission for all voice communication.

Exclusive Layer 2 Features

Equipped with a complete line-up of L2 features, the DGS-1210 Series switches include IGMP Snooping, Port Mirroring, Spanning Tree, and Link Aggregation Control Protocol (LACP). The IEEE 802.3x Flow Control function allows servers to directly connect to the switch for fast, reliable data transfer. At 2000 Mbps Full Duplex, the Gigabit ports provide high-speed data pipes to servers with minimum data transfer loss. Network maintenance features include Loopback Detection and Cable Diagnostics. Loopback Detection is used to detect loops created by a specific port and automatically shut down the affected port. The Cable Diagnostic feature is designed primarily for administrators and customer service representatives, and can rapidly discover the type of error and determine the cable quality.

Secure your Network

D-Link’s innovative Safeguard Engine protects the switches against traffic flooding caused by virus attacks. The switches also support 802.1X port-based authentication, allowing the network clients to be authenticated through external RADIUS servers. In addition, the Access Control List (ACL) feature enhances network security and protects the network by screening traffic from illegal MAC or IP addresses. ARP Spoofing Prevention prevents malicious intruders from sending massive fake ARP messages through a manipulated source. This protects important data from being stolen by Man-in-the-Middle attacks, and prevents wasting CPU cycles on these packets. For added security, the DHCP Server Screening feature blocks rogue DHCP server packets from user ports to prevent unauthorized IP assignment.

Specifications

Management features

MIB supportRFC1213MIB II, RFC1493, RFC1907, RFC1757, 2819, RFC2021, RFC1398, 1643, 1650, 2358, 2665, RFC2674, 4363, RFC 2233, 2863, RFC 2618, RFC 2620, RFC 2925
System event logYes
Traffic classificationYes
Web-based managementYes
Quality of Service (QoS) supportYes
Switch layerL2
Switch typeManaged

Ports & interfaces

Console portRJ-45
Fiber optic connectorSFP
SFP module slots quantity4
Basic switching RJ-45 Ethernet ports typeGigabit Ethernet (10/100/1000)
Basic switching RJ-45 Ethernet ports quantity24
Show all 92 specificationsShow fewer specifications

Network

Number of VLANs4094
Virtual LAN featuresVoice VLAN, Tagged VLAN, MAC address-based VLAN, Port-based VLAN
VLAN supportYes
Link aggregationYes
Flow control supportYes
Auto MDI/MDI-XYes
Auto-negotiationYes
Rate limitingYes
Spanning tree protocolYes
IP routingYes
Full duplexYes
Port mirroringYes
Copper ethernet cabling technology10BASE-T, 100BASE-TX, 100BASE-T, 1000BASE-T
10G supportNo
Networking standardsIEEE 802.1D, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1v, IEEE 802.1w, IEEE 802.1x, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3ah, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z

Optical fiber

Fiber ethernet cabling technology1000BASE-X

Data transmission

Packet buffer memory1.5 MB
Jumbo frames9216
Jumbo frames supportYes
Number of static routes32
Number of queues8
Store-and-forwardYes
Forwarding rate41.7 Mpps
Switching capacity56 Gbit/s
MAC address table16000 entries

Security

Loop protectionYes
Security algorithms802.1x RADIUS, SNMP, SSH
AuthenticationGuest VLAN, MAC-based authentication, Port-based authentication
SSH/SSL supportYes
BPDU filtering/protectionYes
IP-MAC-Port bindingYes
IGMP snoopingYes
Access Control List (ACL) rules256
Access Control List (ACL)Yes
DHCP featuresDHCP client

Multicast features

Multicast Listener Discovery (MLD) snoopingMLD v1, MLD v2
Multicast supportYes

Design

Electromagnetic compatibilityFCC A, CE A, VCCI, C-Tick, BSMI, CCC
SafetyCCC, CE LVD, UL/cUL
Number of fans2 fan(s)
LED indicatorsActivity, Fan fail, Link, Power, Speed
Product colourBlack, Grey
Form factor1U
Rack mountingYes

Performance

Mean time between failures (MTBF)294101 h
Noise level52.4 dB
Flash memory32 MB
Internal memory128 MB
Memory typeDDR3-SDRAM
Built-in processorYes

Power

Power consumption (typical)27.49 W
AC input frequency50 - 60 Hz
AC input voltage100 - 240 V

Power over Ethernet (PoE)

Power over Ethernet (PoE) ports quantity24
Power over Ethernet (PoE)Yes

Operational conditions

Heat dissipation850.58 BTU/h
Storage relative humidity (H-H)5 - 90%
Operating relative humidity (H-H)10 - 90%
Storage temperature (T-T)-40 - 70 °C
Operating temperature (T-T)-5 - 50 °C

Weight & dimensions

Height44 mm
Depth210 mm
Width440 mm

Certificates

CertificationIEC61000-4-5, RoHS

Technical details

Shipping (inner) case height39.3 cm
Shipping (inner) case width29.5 cm
Shipping (inner) case length53.9 cm
Shipping (inner) case net weight15.6 kg
Products per shipping (inner) case3 pc(s)
Pallet gross weight (air)419.7 kg
Master (outer) cases per pallet (air)24 pc(s)
Products per pallet (air)72 pc(s)
Pallet gross length110 cm
Pallet gross width120 cm
Pallet height (air)131.4 cm
Pallet gross weight (sea)682.9 kg
Master (outer) cases per pallet (sea)40 pc(s)
Products per pallet (sea)120 pc(s)
Pallet height (sea)2.1 m
Shipping (inner) case gross weight16.4 kg

Manuals & downloads

  • Image of packaging (PDF)
  • Eu declaration of conformity (PDF)
  • Mmo_32826674_1468937238_7183_19306.pdf (PDF)
  • Manual pdf (PDF)
  • Manual pdf (PDF)

Customer reviews

Delivery & returns

Delivery

  • FREE standard delivery on orders over £50, otherwise £4.95 (3–5 working days).
  • Express delivery £9.99 (1–3 working days) on selected products, UK mainland.
  • PlayStation and Arozzi products use a 5–7 working-day service.
  • Orders are processed within 24 hours, Monday to Friday excluding bank holidays. All deliveries must be signed for.

Returns

  • Changed your mind? Tell us within 14 days of receiving your item, then return it within a further 14 days, unused and in its original packaging. A minimum £9.99 collection fee applies.
  • Faulty or damaged on arrival? Contact us within 48 hours of delivery.
  • Custom-built PCs can only be returned if faulty. Opened headphones, earphones and AirPods can't be returned for hygiene reasons.

Full delivery information · Full returns policy

Similar products

Goes with this

D-Link 28-Port Gigabit PoE+ Smart Managed Switch including 4 x 100/1000Mbps Combo Ports £309.99

Information

  • About us
  • Contact us
  • Our Reviews
  • Shipping Policy
  • Terms & Conditions
  • Privacy & Cookie Policy
  • Fraud Prevention & Security
  • Returns & Refunds
  • Money Wellness (Debt Advice)
  • For Business

Support

  • Delivery Information
  • Manufacturer Warranty
  • Price Match Promise
  • Snap Finance
  • Klarna
  • ClearPay
  • Careers
  • Complaints
  • Vulnerable Customer Policy & TCF
  • Ink & Toner Finder
  • Buying Guides
  • Gaming PC Gift Finder
  • Gaming PC Guide for Parents

My Account

  • Sign In
  • Register
  • Track your order
  • Returns
  • Shop By Brand
  • Affiliate Program
  • FAQ

Contact Us

Head Office:
71-75 Shelton Street, Covent Garden, London, United Kingdom, WC2H 9JQ

Email: hello@backtotheoffice.co.uk

Track your order

Follow Us:

Opens external website in a new window. Opens external website in a new window. Opens external website in a new window.
Visa Mastercard American Express PayPal Clearpay
Klarna Google Pay Apple Pay Snap Finance Float

Snap Finance: Back to the Office is an Introducer Appointed Representative of Snap Finance Limited which is authorised and regulated by the Financial Conduct Authority (Firm reference number 741813). Snap Finance Limited act as the lender.

Pay later with Klarna. Borrowing more than you can afford or paying late may negatively impact your financial status and ability to obtain credit. Subject to status. Ts&Cs and late fees apply. Klarna.com/uk/terms-and-conditions

Clearpay: Clearpay credit subject to status. Ensure you can make repayments on time. You must be 18+ and a permanent UK resident (excl Channel Islands). Clearpay charges a £6 late fee for each late instalment and a further £6 if it’s still unpaid 7 days later. Late fees are capped at £6 for orders under £24 and the lower of £24 or 25% of the order value for orders over £24. Missed payments may affect your future access to credit and your details may be passed onto a debt collection agency working on Clearpay's behalf. T&Cs apply Clearpay.co.uk/terms

Float: Float charges no interest or fees on your instalment plan. Your credit card issuer’s standard terms and conditions, including interest on outstanding balances, will still apply. Please make sure you can comfortably afford each monthly instalment. Float is the trading name of Float Technologies Limited, registered in England and Wales (Company Number: 16558482). Float is not authorised and regulated by the Financial Conduct Authority.

© 2026 Back to the Office.

Your basket

    Your basket is empty

    Start shopping

      Subtotal

      Delivery and any discount codes are calculated at checkout.

      Checkout securely
      View basket