Menu
  • Build your PC in 3D
  • PC Gift Finder
  • Ink Finder
  • Outlet deals

Shop by category

  • Laptops
    • Shop all Laptops
    • Laptops by type
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
      • 2 in 1 Laptops
      • Business Laptops
      • Education Laptops
      • Chromebooks
      • Slim Laptops
      • Refurbished Laptops
    • Popular Searches
      • Laptops under £250
      • Laptops under £500
      • Laptops under £1000
      • 15.6 Inch Laptops
      • 14 Inch Laptops
      • 11.6 Inch Laptops
    • Laptops by brand
      • Microsoft
      • Samsung
      • Apple
      • Lenovo
      • HP
      • ASUS
      • Acer
      • Dell
    • Laptop accessories
      • Bags & Cases
      • Docking Stations
      • Laptop RAM
      • Keyboards
      • Mice
      • Software
      • USB Flash Drives
      • Headsets & Headphones
      • Webcams
      • Privacy Filters
  • PCs
    • Shop all PCs
    • Desktop PCs
      • View All PCs
      • The Gaming Club PCs
      • Gaming PCs
      • Barebone PCs
      • Windows PCs
      • All-In-One PCs
      • iMacs / Mac Minis
    • Custom Build PCs
      • Build a Gaming PC
      • £500 - £999 Gaming PCs
      • £1000 - £1999 Gaming PCs
      • £2000+ Gaming PCs
    • Gaming PCs
      • View All Gaming PCs
    • PC Accessories
      • View all Accessories
      • Storage
      • Keyboards
      • Mice
      • Mouse Mats
      • Headsets
      • Gaming Headsets
      • Webcams
      • Speakers
      • Software
  • Components
    • Components
      • View All Components
    • Graphics Cards
      • View All Graphics Cards
      • NVIDIA Graphics Cards
      • AMD Graphics Cards
      • Intel Graphics Cards
      • NVIDIA 5090 Graphics Cards
      • NVIDIA 5080 Graphics Cards
      • NVIDIA 5070 Graphics Cards
    • Storage
      • View All Storage
      • SSD Drives
      • M.2 SSDs
      • Internal Solid State Drives
      • External Solid State Drives
    • Cooling
      • View All Cooling
      • Liquid Cooling
      • Air Coolers
      • Case Fans
    • Processors
      • View All Processors
      • Intel Processors
      • AMD Processors
    • Memory
      • View All Memory
      • DDR5 RAM
      • DDR4 RAM
      • DDR3 RAM
    • Motherboards
      • View All Motherboards
      • Intel Motherboards
      • AMD Motherboards
    • Power Supplies
      • View All Power Supplies
      • 300W-650W
      • 750W
      • 850W
      • 1000W+
  • Computing
    • Monitors
      • View all Monitors
      • View All Monitors
      • 4K Monitors
      • Gaming Monitors
      • 24" Monitors
      • 27" Monitors
      • 32" Monitors
      • 34" Monitors
      • 35" + Monitors
      • QHD Monitors
      • Ultra Wide Monitors
      • Monitor Mounts & Arms
    • Desktop PCs
      • View All Desktop PCs
      • Gaming PCs
      • Custom Built PCs
      • Apple iMac & Mac Minis
    • Laptops
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
    • Networking
      • View All Networking
      • Whole Home Mesh Wi-Fi
      • Wifi Routers & Modems
      • Network Switches
      • Wireless Access Points
      • Wifi Range Extenders
      • Network Cards
    • Printers & Scanners
      • View All Printers
      • All-In-One Printers
      • Laser Printers
      • Inkjet Printer
      • Label Printers
      • Scanners
    • Ink & Printer Accessories
      • Ink Cartridges
      • Toner Cartridges
      • Paper & Card
      • Shredders
    • Audio
      • Speakers
    • PC Cases
      • View All Cases
      • Full Tower Cases
      • Mid Tower Cases
      • Mini ITX Cases
      • Micro ATX Cases
  • TV & Audio
    • Shop all TV & Audio
    • Televisions
      • View all Televisions
      • View all TVs
      • 55" or more TVs
      • 48" - 54" TVs
      • 42" - 47" TVs
      • 32" - 41" TVs
      • Smaller TVs 32" and Below
      • 4K Ultra HD TVs
    • TV accessories
      • Smart TV Boxes
      • Smart TV Dongles
      • TV stands
      • Remote controls
    • Blu-Ray and Home Cinema
      • Home cinema systems and soundbars
    • Projectors
      • View all Projectors
      • 4K Projectors
      • HD Projectors
    • Speakers & Soundbars
      • View all Speakers
      • Soundbars
      • Portable bluetooth speakers
    • Headphones
      • View all headphones
      • In-ear headphones
      • Over-ear headphones
      • Wired headphones
      • Wireless and bluetooth headphones
      • Sports headphones
  • Gaming
    • Shop all Gaming
    • Gaming PCs and Laptops
      • View all Gaming PCs
      • View all Gaming Laptops
    • Gaming Monitors
      • View all Gaming Monitors
      • 144 HZ + Monitors
      • 4K Monitors
      • Curved Monitors
      • Ultra Wide Monitors
    • Build Your Own Gaming PC
      • Start from Scratch
    • Simulation
      • Flight Simulation
      • Racing Simulation
      • VR Headsets
    • Gaming Accessories
      • View all Gaming Accessories
      • Gaming Chairs
      • Gaming Desks
      • Gaming Keyboards
      • Gaming Mice
      • Gaming Headsets
      • Controllers
      • Gaming Routers
      • Microphones
      • Speakers
      • Streaming
      • Mouse Pads
    • Gaming Components
      • View all Components
      • Graphics Cards
      • Processors
      • Motherboards
      • Memory
      • Cases
      • Cooling
      • Power Supplies
      • Laptop RAM
      • Storage
    • Console Gaming
      • View all Console Gaming
      • Console Storage
      • Xbox Consoles
      • Xbox Controllers
      • Playstation Consoles
      • Playstation Controllers
      • Nintendo Switch Consoles
      • Nintendo Switch Controllers
    • Games
      • PS5 games
      • Xbox games
      • Nintendo Switch games
  • Phones & Tablets
    • Shop all Phones & Tablets
    • Tablets
      • View all Tablets
      • Samsung Tablets
      • Lenovo Tablets
      • Tablet Cases
    • iPads
      • View all iPads
    • Smart Phones
      • View all Smart Phones
      • View all Mobile Phones
      • Mobile Phones (Non-Smart)
      • Apple iPhones
      • Samsung Phones
    • Accessories
      • View all Phone Cases
      • iPhone Cases
      • Samsung Phone Cases
      • Car Chargers
      • Power Banks
      • Mains Chargers
      • Charging Cables
      • Screen Protectors
  • Home & Lifestyle
    • Shop all Home & Lifestyle
    • Smart Home
      • View all Smart Home
      • Video Doorbells
      • Indoor Cameras
      • Outdoor Smart Cameras
      • Smart Lighting
    • Surveillance and Security
      • View all Security Cameras
      • NVR/DVRs
    • Health and Wellbeing
      • View all Health & Wellbeing
      • E-Scooters
      • Smart Watches
      • Activity Trackers
      • Coffee Machines
      • Coffee Grinders
      • Coffee Maker Parts & Accessories
    • Home Office
      • View all Home Office
      • Home Office Desks
      • Home Office Chairs
  • Ink Finder
  • Outlet
  • Sign in
  • Checkout
Back to the Office

Sign in Checkout
  • Laptops
    • Laptops by type
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
      • 2 in 1 Laptops
      • Business Laptops
      • Education Laptops
      • Chromebooks
      • Slim Laptops
      • Refurbished Laptops
    • Popular Searches
      • Laptops under £250
      • Laptops under £500
      • Laptops under £1000
      • 15.6 Inch Laptops
      • 14 Inch Laptops
      • 11.6 Inch Laptops
    • Laptops by brand
      • Microsoft
      • Samsung
      • Apple
      • Lenovo
      • HP
      • ASUS
      • Acer
      • Dell
    • Laptop accessories
      • Bags & Cases
      • Docking Stations
      • Laptop RAM
      • Keyboards
      • Mice
      • Software
      • USB Flash Drives
      • Headsets & Headphones
      • Webcams
      • Privacy Filters
  • PCs
    • Desktop PCs
      • View All PCs
      • The Gaming Club PCs
      • Gaming PCs
      • Barebone PCs
      • Windows PCs
      • All-In-One PCs
      • iMacs / Mac Minis
    • Custom Build PCs
      • Build a Gaming PC
      • £500 - £999 Gaming PCs
      • £1000 - £1999 Gaming PCs
      • £2000+ Gaming PCs
    • Gaming PCs
      • View All Gaming PCs
    • PC Accessories
      • View all Accessories
      • Storage
      • Keyboards
      • Mice
      • Mouse Mats
      • Headsets
      • Gaming Headsets
      • Webcams
      • Speakers
      • Software
  • Components
    • Components
      • View All Components
    • Graphics Cards
      • View All Graphics Cards
      • NVIDIA Graphics Cards
      • AMD Graphics Cards
      • Intel Graphics Cards
      • NVIDIA 5090 Graphics Cards
      • NVIDIA 5080 Graphics Cards
      • NVIDIA 5070 Graphics Cards
    • Storage
      • View All Storage
      • SSD Drives
      • M.2 SSDs
      • Internal Solid State Drives
      • External Solid State Drives
    • Cooling
      • View All Cooling
      • Liquid Cooling
      • Air Coolers
      • Case Fans
    • Processors
      • View All Processors
      • Intel Processors
      • AMD Processors
    • Memory
      • View All Memory
      • DDR5 RAM
      • DDR4 RAM
      • DDR3 RAM
    • Motherboards
      • View All Motherboards
      • Intel Motherboards
      • AMD Motherboards
    • Power Supplies
      • View All Power Supplies
      • 300W-650W
      • 750W
      • 850W
      • 1000W+
  • Computing
    • Monitors
      • View All Monitors
      • 4K Monitors
      • Gaming Monitors
      • 24" Monitors
      • 27" Monitors
      • 32" Monitors
      • 34" Monitors
      • 35" + Monitors
      • QHD Monitors
      • Ultra Wide Monitors
      • Monitor Mounts & Arms
    • Desktop PCs
      • View All Desktop PCs
      • Gaming PCs
      • Custom Built PCs
      • Apple iMac & Mac Minis
    • Laptops
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
    • Networking
      • View All Networking
      • Whole Home Mesh Wi-Fi
      • Wifi Routers & Modems
      • Network Switches
      • Wireless Access Points
      • Wifi Range Extenders
      • Network Cards
    • Printers & Scanners
      • View All Printers
      • All-In-One Printers
      • Laser Printers
      • Inkjet Printer
      • Label Printers
      • Scanners
    • Ink & Printer Accessories
      • Ink Cartridges
      • Toner Cartridges
      • Paper & Card
      • Shredders
    • Audio
      • Speakers
    • PC Cases
      • View All Cases
      • Full Tower Cases
      • Mid Tower Cases
      • Mini ITX Cases
      • Micro ATX Cases
  • TV & Audio
    • Televisions
      • View all TVs
      • 55" or more TVs
      • 48" - 54" TVs
      • 42" - 47" TVs
      • 32" - 41" TVs
      • Smaller TVs 32" and Below
      • 4K Ultra HD TVs
    • TV accessories
      • Smart TV Boxes
      • Smart TV Dongles
      • TV stands
      • Remote controls
    • Blu-Ray and Home Cinema
      • Home cinema systems and soundbars
    • Projectors
      • View all Projectors
      • 4K Projectors
      • HD Projectors
    • Speakers & Soundbars
      • View all Speakers
      • Soundbars
      • Portable bluetooth speakers
    • Headphones
      • View all headphones
      • In-ear headphones
      • Over-ear headphones
      • Wired headphones
      • Wireless and bluetooth headphones
      • Sports headphones
  • Gaming
    • Gaming PCs and Laptops
      • View all Gaming PCs
      • View all Gaming Laptops
    • Gaming Monitors
      • View all Gaming Monitors
      • 144 HZ + Monitors
      • 4K Monitors
      • Curved Monitors
      • Ultra Wide Monitors
    • Build Your Own Gaming PC
      • Start from Scratch
    • Simulation
      • Flight Simulation
      • Racing Simulation
      • VR Headsets
    • Gaming Accessories
      • View all Gaming Accessories
      • Gaming Chairs
      • Gaming Desks
      • Gaming Keyboards
      • Gaming Mice
      • Gaming Headsets
      • Controllers
      • Gaming Routers
      • Microphones
      • Speakers
      • Streaming
      • Mouse Pads
    • Gaming Components
      • View all Components
      • Graphics Cards
      • Processors
      • Motherboards
      • Memory
      • Cases
      • Cooling
      • Power Supplies
      • Laptop RAM
      • Storage
    • Console Gaming
      • View all Console Gaming
      • Console Storage
      • Xbox Consoles
      • Xbox Controllers
      • Playstation Consoles
      • Playstation Controllers
      • Nintendo Switch Consoles
      • Nintendo Switch Controllers
    • Games
      • PS5 games
      • Xbox games
      • Nintendo Switch games
  • Phones & Tablets
    • Tablets
      • View all Tablets
      • Samsung Tablets
      • Lenovo Tablets
      • Tablet Cases
    • iPads
      • View all iPads
    • Smart Phones
      • View all Mobile Phones
      • Mobile Phones (Non-Smart)
      • Apple iPhones
      • Samsung Phones
    • Accessories
      • View all Phone Cases
      • iPhone Cases
      • Samsung Phone Cases
      • Car Chargers
      • Power Banks
      • Mains Chargers
      • Charging Cables
      • Screen Protectors
  • Home & Lifestyle
    • Smart Home
      • View all Smart Home
      • Video Doorbells
      • Indoor Cameras
      • Outdoor Smart Cameras
      • Smart Lighting
    • Surveillance and Security
      • View all Security Cameras
      • NVR/DVRs
    • Health and Wellbeing
      • View all Health & Wellbeing
      • E-Scooters
      • Smart Watches
      • Activity Trackers
      • Coffee Machines
      • Coffee Grinders
      • Coffee Maker Parts & Accessories
    • Home Office
      • View all Home Office
      • Home Office Desks
      • Home Office Chairs
  • Ink Finder
  • Outlet
Home D-Link 26-Port PoE+ Gigabit Smart Managed Switch
D-Link 26-Port PoE+ Gigabit Smart Managed Switch
D-Link 26-Port PoE+ Gigabit Smart Managed Switch - image 2
D-Link 26-Port PoE+ Gigabit Smart Managed Switch - image 3
1 / 3
D-Link 26-Port PoE+ Gigabit Smart Managed Switch
D-Link 26-Port PoE+ Gigabit Smart Managed Switch - image 2
D-Link 26-Port PoE+ Gigabit Smart Managed Switch - image 3
D-Link 26-Port PoE+ Gigabit Smart Managed Switch
D-Link 26-Port PoE+ Gigabit Smart Managed Switch - image 2
D-Link 26-Port PoE+ Gigabit Smart Managed Switch - image 3

D-Link 26-Port PoE+ Gigabit Smart Managed Switch

D-Link · MPN: DGS-1100-26MPV2
Sale!
from £227.99
/per
inc. VAT
Spread the cost with Klarna, Clearpay, PayPal or FloatFrom 3 interest-free payments of £75.99 See options

Credit subject to status. 18+, UK residents only. See each provider for terms.

In stock

FREE delivery

Express £9.99

 
 
More payment options Snap Finance Snap Finance on orders over £250
Snap Finance

Snap Finance on orders over £250

Pay £1 deposit · Pay in 4 available · Decision in minutes

Soft check, won't affect your credit score. Representative 29.9% APR. Choose Snap Finance at checkout.

How Snap Finance works

Credit subject to status. 18+, UK residents only. Back to the Office is an Introducer Appointed Representative of Snap Finance Limited, which is authorised and regulated by the Financial Conduct Authority (FRN 741813). Snap Finance Limited is the lender.

We accept all of these. Choose the one you want at checkout.

  • American Express
  • Apple Pay
  • Google Pay
  • Maestro
  • Mastercard
  • PayPal
  • Shop Pay
  • Visa
  • Express checkout Shop Pay, Apple Pay, Google Pay and PayPal
  • Card Visa, Mastercard, American Express and Maestro
  • Pay later Snap Finance, Klarna, Clearpay, PayPal Pay in 3 and more
Go to checkout with this item

Secure checkout. You can add a discount code or gift card on the next page.

Price drop alert

D-Link 26-Port PoE+ Gigabit Smart Managed Switch
Now £227.99

We'll email you if the price of this item drops in the next 90 days.

By setting an alert you agree to receive price drop emails from Back to the Office for this item and others you view. No newsletters. Unsubscribe at any time. Privacy policy

Alert set

We'll email if the price of D-Link 26-Port PoE+ Gigabit Smart Managed Switch drops.

  • 14-day returns Details
  • UK manufacturer warranty Details
  • Price Match Promise Details
  • Rated 4.9/5 by customers on Trustpilot & Feefo Read reviews
OverviewSpecificationsManuals & downloadsReviews Delivery & returns

Overview

  • Simple Layer 2 Management
  • Web-based User Interface
  • PoE options up to 370W power budget
  • Limited-Lifetime Warranty after registration

Smart Web UI
The DGS-1100's web user interface is an easy way to manage Layer 2 features, such as VLANs, Spanning Tree Protocol (STP), link aggregation (static). With powerful security features like IGMP snooping, Static MAC, and Storm Control, the DGS-1100 Smart family is a versatile solution for environments that require easy to deploy and easy to configure solutions without added complexities.

Easy to Deploy and Manage
D-Link’s free Network Assistant (DNA) displays all connected devices and speeds up the first time configuration. The free D-View 7 Network Management System comes with a license for 25 nodes and 2 probes and full access to the management tools. Optional upgrade licenses allow you to broaden your network and analysis.

PoE and Poe+, with budgets up to 370W
The DGS-1100 Smart Series includes a range of high power budget PoE-enabled switches for businesses looking to power larger deployments of VoIP phones, wireless access points or network cameras.

Easy Troubleshooting
The DGS-1100 Series features Loopback Detection and Cable Diagnostics to help network administrators find and solve network problems quickly and easily.

Loopback Detection is used to detect loops created by a specific port and automatically shut down the affected port. The Cable Diagnostics feature is designed for network administrators to quickly examine the quality of the copper cables, recognise the cable type, and detect cable errors.

Green Technology
D-Link Green technology enables the DGS-1100 Smart series to save power without sacrifices. The majority of the family utilises a fanless design, for silent and energy efficient operation. All are IEEE 802.3az compliant and feature Link Status detection and Time-Based PoE (excluding DGS-1100-05PD and DGS-1100-08P models).

Surveillance Mode
Select Surveillance Mode in the Web UI to take advantage of easy‑to‑use surveillance features which also enable you to manage your surveillance network effortlessly. It automatically detects your security devices and segments them into a dedicated Auto Surveillance VLAN to handle video surveillance traffic securely and efficiently.

Specifications

Management features

MIB support• RFC768 UDP • RFC791 IP • RFC792 ICMP • RFC793 TCP • RFC826 ARP • RFC1213 MIB II • RFC1493 Bridage MIB • RFC1907 SNMPv2 MIB • RFC1215 MIB Traps Convention
ARP inspectionYes
Web-based managementYes
Quality of Service (QoS) supportYes
Switch layerL2
Switch typeManaged

Ports & interfaces

Combo SFP ports quantity2
Basic switching RJ-45 Ethernet ports typeGigabit Ethernet (10/100/1000)
Basic switching RJ-45 Ethernet ports quantity24
Show all 61 specificationsShow fewer specifications

Network

Virtual LAN featuresPort-based VLAN, Voice VLAN
VLAN supportYes
Link aggregationYes
Flow control supportYes
Auto MDI/MDI-XYes
Auto-negotiationYes
Rate limitingYes
Broadcast storm controlYes
Spanning tree protocolYes
Head-of-line (HOL) blockingYes
Half duplexYes
Full duplexYes
Port mirroringYes
Copper ethernet cabling technology10GBASE-T, 1000BASE-T
Networking standardsIEEE 802.1D, IEEE 802.1w, IEEE 802.3af, IEEE 802.3at

Data transmission

Jumbo frames supportYes
Forwarding rate38.69 Mpps
Switching capacity52 Gbit/s
MAC address table8000 entries

Security

Security algorithmsSSL/TLS
MAC address filteringYes
Static port securityYes
IGMP snoopingYes
DHCP featuresDHCP client

Multicast features

Number of multicast groups filtered1
IPv6 multicast entries1
IPv4 multicast entries1
Multicast supportYes

Protocols

IPv4 & IPv6 featuresIPv4 FIB

Design

Housing materialMetal
Product colourBlack
Rack mountingYes

Performance

FanlessYes
Noise level50.5 dB
Flash memory16 MB

Power

Power consumption (max)454.1 W
AC input frequency50 - 60 Hz
AC input voltage100 - 240 V
Power supply includedYes

Power over Ethernet (PoE)

Total Power over Ethernet (PoE) budget370 W
Power over Ethernet plus (PoE+) ports quantity24
Power over Ethernet (PoE) ports quantity24
Power over Ethernet (PoE)Yes

Operational conditions

Heat dissipation287 BTU/h
Storage relative humidity (H-H)0 - 95%
Operating relative humidity (H-H)0 - 95%
Storage temperature (T-T)-40 - 70 °C
Operating temperature (T-T)-10 - 50 °C

Weight & dimensions

Weight2.8 kg
Height44 mm
Depth208 mm
Width440 mm

Manuals & downloads

  • Image of packaging (PDF)
  • Eu declaration of conformity (PDF)
  • Leaflet (PDF)
  • Manual pdf (PDF)

Customer reviews

Delivery & returns

Delivery

  • FREE standard delivery on orders over £50, otherwise £4.95 (3–5 working days).
  • Express delivery £9.99 (1–3 working days) on selected products, UK mainland.
  • PlayStation and Arozzi products use a 5–7 working-day service.
  • Orders are processed within 24 hours, Monday to Friday excluding bank holidays. All deliveries must be signed for.

Returns

  • Changed your mind? Tell us within 14 days of receiving your item, then return it within a further 14 days, unused and in its original packaging. A minimum £9.99 collection fee applies.
  • Faulty or damaged on arrival? Contact us within 48 hours of delivery.
  • Custom-built PCs can only be returned if faulty. Opened headphones, earphones and AirPods can't be returned for hygiene reasons.

Full delivery information · Full returns policy

Similar products

Goes with this

D-Link 26-Port PoE+ Gigabit Smart Managed Switch £227.99

Information

  • About us
  • Contact us
  • Our Reviews
  • Shipping Policy
  • Terms & Conditions
  • Privacy & Cookie Policy
  • Fraud Prevention & Security
  • Returns & Refunds
  • Money Wellness (Debt Advice)
  • For Business

Support

  • Delivery Information
  • Manufacturer Warranty
  • Price Match Promise
  • Snap Finance
  • Klarna
  • ClearPay
  • Careers
  • Complaints
  • Vulnerable Customer Policy & TCF
  • Ink & Toner Finder
  • Buying Guides
  • Gaming PC Gift Finder
  • Gaming PC Guide for Parents

My Account

  • Sign In
  • Register
  • Track your order
  • Returns
  • Shop By Brand
  • Affiliate Program
  • FAQ

Contact Us

Head Office:
71-75 Shelton Street, Covent Garden, London, United Kingdom, WC2H 9JQ

Email: hello@backtotheoffice.co.uk

Track your order

Follow Us:

Opens external website in a new window. Opens external website in a new window. Opens external website in a new window.
Visa Mastercard American Express PayPal Clearpay
Klarna Google Pay Apple Pay Snap Finance Float

Snap Finance: Back to the Office is an Introducer Appointed Representative of Snap Finance Limited which is authorised and regulated by the Financial Conduct Authority (Firm reference number 741813). Snap Finance Limited act as the lender.

Pay later with Klarna. Borrowing more than you can afford or paying late may negatively impact your financial status and ability to obtain credit. Subject to status. Ts&Cs and late fees apply. Klarna.com/uk/terms-and-conditions

Clearpay: Clearpay credit subject to status. Ensure you can make repayments on time. You must be 18+ and a permanent UK resident (excl Channel Islands). Clearpay charges a £6 late fee for each late instalment and a further £6 if it’s still unpaid 7 days later. Late fees are capped at £6 for orders under £24 and the lower of £24 or 25% of the order value for orders over £24. Missed payments may affect your future access to credit and your details may be passed onto a debt collection agency working on Clearpay's behalf. T&Cs apply Clearpay.co.uk/terms

Float: Float charges no interest or fees on your instalment plan. Your credit card issuer’s standard terms and conditions, including interest on outstanding balances, will still apply. Please make sure you can comfortably afford each monthly instalment. Float is the trading name of Float Technologies Limited, registered in England and Wales (Company Number: 16558482). Float is not authorised and regulated by the Financial Conduct Authority.

© 2026 Back to the Office.

Your basket

    Your basket is empty

    Start shopping

      Subtotal

      Delivery and any discount codes are calculated at checkout.

      Checkout securely
      View basket