D-Link 24-port Gigabit Smart Managed Switch with 4x 10G SFP+
Spread the cost with Klarna, Clearpay, PayPal or FloatFrom 3 interest-free payments of £66.66 See options
Credit subject to status. 18+, UK residents only. See each provider for terms.
In stock
FREE delivery
Express £9.99
Couldn't load pickup availability
- 14-day returns Details
- UK manufacturer warranty Details
- Price Match Promise Details
- Rated 4.9/5 by customers on Trustpilot & Feefo Read reviews
Overview
- 24 x 10/100/1000BASE-T ports
- 4 x 10G SFP+ ports
- Lite L3 Static Routing
- Advanced security features, IMPB, 802.1X Authentication
- Dual Image & Configuration
- Supports STP/RSTP/MSTP
- Full CLI
- QoS Enablement
- 11 Web Languages
Power & Value
The D-Link DGS-1250 Series Smart Managed Switches deliver real value as an Enterprise Access and Small-to-Medium Business (SMB) Access/Aggregation solution. They provide a range of physical interfaces (including a Console Port w/full CLI), multiple management interfaces, 11 Web languages, QoS enablement, and Advanced Layer-2 w/Lite Layer-3 features.
The DGS-1250 Series switches support 24 or 48 x 10/100/1000BASE-T ports, with each switch also supporting an additional 4 x 10G SFP+ ports for optical connections using multimode or single-mode SFP transceivers – enabling real network horsepower at a value price.
Easy Maintenance, Less Downtime
The DGS-1250 Series supports Dual Image and Dual Configuration functionality, as well as a Console Port, all of which make it easier to configure, troubleshoot, and make other changes without interfering with network operation, while full Command Line Interface (CLI) functionality enables remote configuration, without the need for the Internet. And if a network issue ever does occur, the supported Spanning Tree Protocols (STP/RSTP/MSTP) help keep things running without interruptions or downtime.
Automatic Configuration
The DGS-1250 Series supports Auto Voice VLAN and Surveillance Mode, which allow Voice and Video traffic to be automatically identified and handled differently from regular network traffic. Auto Voice VLAN detects Voice over IP (VoIP) traffic and automatically segments it from the rest of the network, increasing security and allowing Quality of Service (QoS) to be applied.
Extensive Management and Advanced Features
The DGS-1250 Series comes with IGMP snooping, Port Mirroring, Spanning Tree Protocol (STP), and Link Aggregation Control Protocol (LACP). The IEEE 802.3x Flow Control function allows servers to directly connect to the switch for fast, reliable data transfers. The series also supports advanced features such as Static Routing, which allows for communication between different user groups in different VLAN segments in a network.
Management Versatility
The DGS-1250 Series comes with the D-Link Network Assistant (DNA) utility so admins can remotely control their network to the port level. DNA allows customers to easily discover multiple D-Link Smart Managed Switches within the same L2 network segment and display them onscreen for instant access.
Specifications
Management features
| Switch type | Managed |
|---|---|
| Switch layer | L3 |
| Quality of Service (QoS) support | Yes |
| Web-based management | Yes |
| Configuring Location Settings (CLI) | Yes |
| ARP inspection | Yes |
| System event log | Yes |
| MIB support | RFC2893, RFC4213, RFC4291, RFC2464, RFC2462, RFC4862, RFC2461, RFC4861, RFC2573, RFC1321, RFC2284, RFC2865, RFC2716, RFC3580, RFC826, RFC2463, RFC4443, RFC792, RFC793, RFC768, RFC791, RFC2389, RFC4113, RFC4022, RFC2618, RFC2674, RFC1398, RFC1643, RFC1650, RFC2358, RFC2665, RFC2021, RFC271, RFC1757, RFC2819, RFC1442, RFC1901, RFC1902, RFC1903, RFC1904, RFC1905, RFC1906, RFC1907, RFC1908, RFC2578, RFC3418, RFC2573, RFC2575, RFC2576, RFC1212, RFC1213, RFC1215, RFC1493, RFC1157, RFC2620, |
Ports & interfaces
| Basic switching RJ-45 Ethernet ports quantity | 24 |
|---|---|
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| SFP+ module slots quantity | 4 |
| Console port | RJ-45 |
Show all 87 specificationsShow fewer specifications
Network
| Networking standards | IEEE 802.1D, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3ae, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z |
|---|---|
| 10G support | Yes |
| Copper ethernet cabling technology | 10BASE-T, 100BASE-TX, 1000BASE-T |
| Cable types supported | Cat5, Cat5e |
| Port mirroring | Yes |
| Full duplex | Yes |
| Head-of-line (HOL) blocking | Yes |
| Spanning tree protocol | Yes |
| Broadcast storm control | Yes |
| Link aggregation | Yes |
| Auto MDI/MDI-X | Yes |
| Flow control support | Yes |
| VLAN support | Yes |
| Virtual LAN features | Voice VLAN |
| Number of VLANs | 4094 |
Optical fiber
| Fiber ethernet cabling technology | 100BASE-FX, 1000BASE-LHX, 1000BASE-X, 1000BASE‑LX, 1000BASE‑SX, 1000BASE‑ZX |
|---|
Data transmission
| MAC address table | 16000 entries |
|---|---|
| Switching capacity | 128 Gbit/s |
| Forwarding rate | 95.24 Mpps |
| Store-and-forward | Yes |
| Static route | Yes |
| Number of static routes | 124 |
| Jumbo frames support | Yes |
| Jumbo frames | 12000 |
| Packet buffer memory | 12 MB |
Security
| DHCP features | DHCP client, DHCP server, DHCP snooping |
|---|---|
| Access Control List (ACL) | Yes |
| Access Control List (ACL) rules | 768 |
| IGMP snooping | Yes |
| IP-MAC-Port binding | Yes |
| Queue scheduling algorithms | Weighted Round Robin (WRR) |
| Security algorithms | EAP, MD5, PEAP, SSH, SSL/TLS, TTLS |
| Loop protection | Yes |
Multicast features
| Multicast support | Yes |
|---|
Design
| Rack mounting | Yes |
|---|---|
| Product colour | Black |
| LED indicators | Activity, Link, Power, Speed |
| Electromagnetic compatibility | CE A, VCCI A, FCC A, IC, BSMI |
Performance
| Memory type | DDR3-SDRAM |
|---|---|
| Internal memory | 2048 MB |
| Flash memory | 64 MB |
| Firmware upgradeable | Yes |
| Noise level | 47.6 dB |
| Mean time between failures (MTBF) | 743482.45 h |
Power
| Power supply included | Yes |
|---|---|
| AC input voltage | 100 - 240 V |
| AC input frequency | 50 - 60 Hz |
| Power consumption (max) | 30.6 W |
Power over Ethernet (PoE)
| Power over Ethernet (PoE) | No |
|---|
Operational conditions
| Operating temperature (T-T) | -5 - 50 °C |
|---|---|
| Storage temperature (T-T) | -20 - 70 °C |
| Operating relative humidity (H-H) | 0 - 95% |
| Storage relative humidity (H-H) | 0 - 95% |
| Heat dissipation | 104.346 BTU/h |
Weight & dimensions
| Width | 440 mm |
|---|---|
| Depth | 140 mm |
| Height | 44 mm |
| Weight | 3.86 kg |
Certificates
| Certification | CB, UL, BSMI, CCC |
|---|
Technical details
| Shipping (inner) case gross weight | 16.2 kg |
|---|---|
| Pallet height (sea) | 2.04 m |
| Products per pallet (sea) | 120 pc(s) |
| Master (outer) cases per pallet (sea) | 24 pc(s) |
| Pallet gross weight (sea) | 407.6 kg |
| Pallet height (air) | 2.04 m |
| Pallet gross width | 120 cm |
| Pallet gross length | 110 cm |
| Products per pallet (air) | 120 pc(s) |
| Master (outer) cases per pallet (air) | 24 pc(s) |
| Pallet gross weight (air) | 407.6 kg |
| Products per shipping (inner) case | 5 pc(s) |
| Shipping (inner) case net weight | 11.6 kg |
| Shipping (inner) case length | 58.5 cm |
| Shipping (inner) case width | 47.8 cm |
| Shipping (inner) case height | 31.8 cm |
Manuals & downloads
Customer reviews
Delivery & returns
Delivery
- FREE standard delivery on orders over £50, otherwise £4.95 (3–5 working days).
- Express delivery £9.99 (1–3 working days) on selected products, UK mainland.
- PlayStation and Arozzi products use a 5–7 working-day service.
- Orders are processed within 24 hours, Monday to Friday excluding bank holidays. All deliveries must be signed for.
Returns
- Changed your mind? Tell us within 14 days of receiving your item, then return it within a further 14 days, unused and in its original packaging. A minimum £9.99 collection fee applies.
- Faulty or damaged on arrival? Contact us within 48 hours of delivery.
- Custom-built PCs can only be returned if faulty. Opened headphones, earphones and AirPods can't be returned for hygiene reasons.