Menu
  • Build your PC in 3D
  • PC Gift Finder
  • Ink Finder
  • Outlet deals

Shop by category

  • Laptops
    • Shop all Laptops
    • Laptops by type
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
      • 2 in 1 Laptops
      • Business Laptops
      • Education Laptops
      • Chromebooks
      • Slim Laptops
      • Refurbished Laptops
    • Popular Searches
      • Laptops under £250
      • Laptops under £500
      • Laptops under £1000
      • 15.6 Inch Laptops
      • 14 Inch Laptops
      • 11.6 Inch Laptops
    • Laptops by brand
      • Microsoft
      • Samsung
      • Apple
      • Lenovo
      • HP
      • ASUS
      • Acer
      • Dell
    • Laptop accessories
      • Bags & Cases
      • Docking Stations
      • Laptop RAM
      • Keyboards
      • Mice
      • Software
      • USB Flash Drives
      • Headsets & Headphones
      • Webcams
      • Privacy Filters
  • PCs
    • Shop all PCs
    • Desktop PCs
      • View All PCs
      • The Gaming Club PCs
      • Gaming PCs
      • Barebone PCs
      • Windows PCs
      • All-In-One PCs
      • iMacs / Mac Minis
    • Custom Build PCs
      • Build a Gaming PC
      • £500 - £999 Gaming PCs
      • £1000 - £1999 Gaming PCs
      • £2000+ Gaming PCs
    • Gaming PCs
      • View All Gaming PCs
    • PC Accessories
      • View all Accessories
      • Storage
      • Keyboards
      • Mice
      • Mouse Mats
      • Headsets
      • Gaming Headsets
      • Webcams
      • Speakers
      • Software
  • Components
    • Components
      • View All Components
    • Graphics Cards
      • View All Graphics Cards
      • NVIDIA Graphics Cards
      • AMD Graphics Cards
      • Intel Graphics Cards
      • NVIDIA 5090 Graphics Cards
      • NVIDIA 5080 Graphics Cards
      • NVIDIA 5070 Graphics Cards
    • Storage
      • View All Storage
      • SSD Drives
      • M.2 SSDs
      • Internal Solid State Drives
      • External Solid State Drives
    • Cooling
      • View All Cooling
      • Liquid Cooling
      • Air Coolers
      • Case Fans
    • Processors
      • View All Processors
      • Intel Processors
      • AMD Processors
    • Memory
      • View All Memory
      • DDR5 RAM
      • DDR4 RAM
      • DDR3 RAM
    • Motherboards
      • View All Motherboards
      • Intel Motherboards
      • AMD Motherboards
    • Power Supplies
      • View All Power Supplies
      • 300W-650W
      • 750W
      • 850W
      • 1000W+
  • Computing
    • Monitors
      • View all Monitors
      • View All Monitors
      • 4K Monitors
      • Gaming Monitors
      • 24" Monitors
      • 27" Monitors
      • 32" Monitors
      • 34" Monitors
      • 35" + Monitors
      • QHD Monitors
      • Ultra Wide Monitors
      • Monitor Mounts & Arms
    • Desktop PCs
      • View All Desktop PCs
      • Gaming PCs
      • Custom Built PCs
      • Apple iMac & Mac Minis
    • Laptops
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
    • Networking
      • View All Networking
      • Whole Home Mesh Wi-Fi
      • Wifi Routers & Modems
      • Network Switches
      • Wireless Access Points
      • Wifi Range Extenders
      • Network Cards
    • Printers & Scanners
      • View All Printers
      • All-In-One Printers
      • Laser Printers
      • Inkjet Printer
      • Label Printers
      • Scanners
    • Ink & Printer Accessories
      • Ink Cartridges
      • Toner Cartridges
      • Paper & Card
      • Shredders
    • Audio
      • Speakers
    • PC Cases
      • View All Cases
      • Full Tower Cases
      • Mid Tower Cases
      • Mini ITX Cases
      • Micro ATX Cases
  • TV & Audio
    • Shop all TV & Audio
    • Televisions
      • View all Televisions
      • View all TVs
      • 55" or more TVs
      • 48" - 54" TVs
      • 42" - 47" TVs
      • 32" - 41" TVs
      • Smaller TVs 32" and Below
      • 4K Ultra HD TVs
    • TV accessories
      • Smart TV Boxes
      • Smart TV Dongles
      • TV stands
      • Remote controls
    • Blu-Ray and Home Cinema
      • Home cinema systems and soundbars
    • Projectors
      • View all Projectors
      • 4K Projectors
      • HD Projectors
    • Speakers & Soundbars
      • View all Speakers
      • Soundbars
      • Portable bluetooth speakers
    • Headphones
      • View all headphones
      • In-ear headphones
      • Over-ear headphones
      • Wired headphones
      • Wireless and bluetooth headphones
      • Sports headphones
  • Gaming
    • Shop all Gaming
    • Gaming PCs and Laptops
      • View all Gaming PCs
      • View all Gaming Laptops
    • Gaming Monitors
      • View all Gaming Monitors
      • 144 HZ + Monitors
      • 4K Monitors
      • Curved Monitors
      • Ultra Wide Monitors
    • Build Your Own Gaming PC
      • Start from Scratch
    • Simulation
      • Flight Simulation
      • Racing Simulation
      • VR Headsets
    • Gaming Accessories
      • View all Gaming Accessories
      • Gaming Chairs
      • Gaming Desks
      • Gaming Keyboards
      • Gaming Mice
      • Gaming Headsets
      • Controllers
      • Gaming Routers
      • Microphones
      • Speakers
      • Streaming
      • Mouse Pads
    • Gaming Components
      • View all Components
      • Graphics Cards
      • Processors
      • Motherboards
      • Memory
      • Cases
      • Cooling
      • Power Supplies
      • Laptop RAM
      • Storage
    • Console Gaming
      • View all Console Gaming
      • Console Storage
      • Xbox Consoles
      • Xbox Controllers
      • Playstation Consoles
      • Playstation Controllers
      • Nintendo Switch Consoles
      • Nintendo Switch Controllers
    • Games
      • PS5 games
      • Xbox games
      • Nintendo Switch games
  • Phones & Tablets
    • Shop all Phones & Tablets
    • Tablets
      • View all Tablets
      • Samsung Tablets
      • Lenovo Tablets
      • Tablet Cases
    • iPads
      • View all iPads
    • Smart Phones
      • View all Smart Phones
      • View all Mobile Phones
      • Mobile Phones (Non-Smart)
      • Apple iPhones
      • Samsung Phones
    • Accessories
      • View all Phone Cases
      • iPhone Cases
      • Samsung Phone Cases
      • Car Chargers
      • Power Banks
      • Mains Chargers
      • Charging Cables
      • Screen Protectors
  • Home & Lifestyle
    • Shop all Home & Lifestyle
    • Smart Home
      • View all Smart Home
      • Video Doorbells
      • Indoor Cameras
      • Outdoor Smart Cameras
      • Smart Lighting
    • Surveillance and Security
      • View all Security Cameras
      • NVR/DVRs
    • Health and Wellbeing
      • View all Health & Wellbeing
      • E-Scooters
      • Smart Watches
      • Activity Trackers
      • Coffee Machines
      • Coffee Grinders
      • Coffee Maker Parts & Accessories
    • Home Office
      • View all Home Office
      • Home Office Desks
      • Home Office Chairs
  • Ink Finder
  • Outlet
  • Sign in
  • Checkout
Back to the Office

Sign in Checkout
  • Laptops
    • Laptops by type
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
      • 2 in 1 Laptops
      • Business Laptops
      • Education Laptops
      • Chromebooks
      • Slim Laptops
      • Refurbished Laptops
    • Popular Searches
      • Laptops under £250
      • Laptops under £500
      • Laptops under £1000
      • 15.6 Inch Laptops
      • 14 Inch Laptops
      • 11.6 Inch Laptops
    • Laptops by brand
      • Microsoft
      • Samsung
      • Apple
      • Lenovo
      • HP
      • ASUS
      • Acer
      • Dell
    • Laptop accessories
      • Bags & Cases
      • Docking Stations
      • Laptop RAM
      • Keyboards
      • Mice
      • Software
      • USB Flash Drives
      • Headsets & Headphones
      • Webcams
      • Privacy Filters
  • PCs
    • Desktop PCs
      • View All PCs
      • The Gaming Club PCs
      • Gaming PCs
      • Barebone PCs
      • Windows PCs
      • All-In-One PCs
      • iMacs / Mac Minis
    • Custom Build PCs
      • Build a Gaming PC
      • £500 - £999 Gaming PCs
      • £1000 - £1999 Gaming PCs
      • £2000+ Gaming PCs
    • Gaming PCs
      • View All Gaming PCs
    • PC Accessories
      • View all Accessories
      • Storage
      • Keyboards
      • Mice
      • Mouse Mats
      • Headsets
      • Gaming Headsets
      • Webcams
      • Speakers
      • Software
  • Components
    • Components
      • View All Components
    • Graphics Cards
      • View All Graphics Cards
      • NVIDIA Graphics Cards
      • AMD Graphics Cards
      • Intel Graphics Cards
      • NVIDIA 5090 Graphics Cards
      • NVIDIA 5080 Graphics Cards
      • NVIDIA 5070 Graphics Cards
    • Storage
      • View All Storage
      • SSD Drives
      • M.2 SSDs
      • Internal Solid State Drives
      • External Solid State Drives
    • Cooling
      • View All Cooling
      • Liquid Cooling
      • Air Coolers
      • Case Fans
    • Processors
      • View All Processors
      • Intel Processors
      • AMD Processors
    • Memory
      • View All Memory
      • DDR5 RAM
      • DDR4 RAM
      • DDR3 RAM
    • Motherboards
      • View All Motherboards
      • Intel Motherboards
      • AMD Motherboards
    • Power Supplies
      • View All Power Supplies
      • 300W-650W
      • 750W
      • 850W
      • 1000W+
  • Computing
    • Monitors
      • View All Monitors
      • 4K Monitors
      • Gaming Monitors
      • 24" Monitors
      • 27" Monitors
      • 32" Monitors
      • 34" Monitors
      • 35" + Monitors
      • QHD Monitors
      • Ultra Wide Monitors
      • Monitor Mounts & Arms
    • Desktop PCs
      • View All Desktop PCs
      • Gaming PCs
      • Custom Built PCs
      • Apple iMac & Mac Minis
    • Laptops
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
    • Networking
      • View All Networking
      • Whole Home Mesh Wi-Fi
      • Wifi Routers & Modems
      • Network Switches
      • Wireless Access Points
      • Wifi Range Extenders
      • Network Cards
    • Printers & Scanners
      • View All Printers
      • All-In-One Printers
      • Laser Printers
      • Inkjet Printer
      • Label Printers
      • Scanners
    • Ink & Printer Accessories
      • Ink Cartridges
      • Toner Cartridges
      • Paper & Card
      • Shredders
    • Audio
      • Speakers
    • PC Cases
      • View All Cases
      • Full Tower Cases
      • Mid Tower Cases
      • Mini ITX Cases
      • Micro ATX Cases
  • TV & Audio
    • Televisions
      • View all TVs
      • 55" or more TVs
      • 48" - 54" TVs
      • 42" - 47" TVs
      • 32" - 41" TVs
      • Smaller TVs 32" and Below
      • 4K Ultra HD TVs
    • TV accessories
      • Smart TV Boxes
      • Smart TV Dongles
      • TV stands
      • Remote controls
    • Blu-Ray and Home Cinema
      • Home cinema systems and soundbars
    • Projectors
      • View all Projectors
      • 4K Projectors
      • HD Projectors
    • Speakers & Soundbars
      • View all Speakers
      • Soundbars
      • Portable bluetooth speakers
    • Headphones
      • View all headphones
      • In-ear headphones
      • Over-ear headphones
      • Wired headphones
      • Wireless and bluetooth headphones
      • Sports headphones
  • Gaming
    • Gaming PCs and Laptops
      • View all Gaming PCs
      • View all Gaming Laptops
    • Gaming Monitors
      • View all Gaming Monitors
      • 144 HZ + Monitors
      • 4K Monitors
      • Curved Monitors
      • Ultra Wide Monitors
    • Build Your Own Gaming PC
      • Start from Scratch
    • Simulation
      • Flight Simulation
      • Racing Simulation
      • VR Headsets
    • Gaming Accessories
      • View all Gaming Accessories
      • Gaming Chairs
      • Gaming Desks
      • Gaming Keyboards
      • Gaming Mice
      • Gaming Headsets
      • Controllers
      • Gaming Routers
      • Microphones
      • Speakers
      • Streaming
      • Mouse Pads
    • Gaming Components
      • View all Components
      • Graphics Cards
      • Processors
      • Motherboards
      • Memory
      • Cases
      • Cooling
      • Power Supplies
      • Laptop RAM
      • Storage
    • Console Gaming
      • View all Console Gaming
      • Console Storage
      • Xbox Consoles
      • Xbox Controllers
      • Playstation Consoles
      • Playstation Controllers
      • Nintendo Switch Consoles
      • Nintendo Switch Controllers
    • Games
      • PS5 games
      • Xbox games
      • Nintendo Switch games
  • Phones & Tablets
    • Tablets
      • View all Tablets
      • Samsung Tablets
      • Lenovo Tablets
      • Tablet Cases
    • iPads
      • View all iPads
    • Smart Phones
      • View all Mobile Phones
      • Mobile Phones (Non-Smart)
      • Apple iPhones
      • Samsung Phones
    • Accessories
      • View all Phone Cases
      • iPhone Cases
      • Samsung Phone Cases
      • Car Chargers
      • Power Banks
      • Mains Chargers
      • Charging Cables
      • Screen Protectors
  • Home & Lifestyle
    • Smart Home
      • View all Smart Home
      • Video Doorbells
      • Indoor Cameras
      • Outdoor Smart Cameras
      • Smart Lighting
    • Surveillance and Security
      • View all Security Cameras
      • NVR/DVRs
    • Health and Wellbeing
      • View all Health & Wellbeing
      • E-Scooters
      • Smart Watches
      • Activity Trackers
      • Coffee Machines
      • Coffee Grinders
      • Coffee Maker Parts & Accessories
    • Home Office
      • View all Home Office
      • Home Office Desks
      • Home Office Chairs
  • Ink Finder
  • Outlet
Home D-Link 24-port Gigabit PoE Smart Managed Switch with 4x 10G
D-Link 24-port Gigabit PoE Smart Managed Switch with 4x 10G SFP+, 370Watts
D-Link 24-port Gigabit PoE Smart Managed Switch with 4x 10G SFP+, 370Watts - image 2
D-Link 24-port Gigabit PoE Smart Managed Switch with 4x 10G SFP+, 370Watts - image 3
1 / 3
D-Link 24-port Gigabit PoE Smart Managed Switch with 4x 10G SFP+, 370Watts
D-Link 24-port Gigabit PoE Smart Managed Switch with 4x 10G SFP+, 370Watts - image 2
D-Link 24-port Gigabit PoE Smart Managed Switch with 4x 10G SFP+, 370Watts - image 3
D-Link 24-port Gigabit PoE Smart Managed Switch with 4x 10G SFP+, 370Watts
D-Link 24-port Gigabit PoE Smart Managed Switch with 4x 10G SFP+, 370Watts - image 2
D-Link 24-port Gigabit PoE Smart Managed Switch with 4x 10G SFP+, 370Watts - image 3

D-Link 24-port Gigabit PoE Smart Managed Switch with 4x 10G SFP+, 370Watts

D-Link · MPN: DGS-1250-28XMP
Sale!
from £345.99
/per
inc. VAT
Spread the cost with Klarna, Clearpay, PayPal, Float or SnapFrom 3 interest-free payments of £115.33 See options

Credit subject to status. 18+, UK residents only. See each provider for terms.

Key specs

  • Internal memory2048 MB
  • Weight3.46 kg
All specifications

In stock

FREE delivery

Express £9.99

 
 
More payment options Snap Finance Spread the cost up to 4 years
Snap Finance

Spread the cost up to 4 years with Snap Finance

Pay £1 deposit · Pay in 4 available · Decision in minutes

Soft check, won't affect your credit score. Representative 29.9% APR. Choose Snap Finance at checkout.

How Snap Finance works

Credit subject to status. 18+, UK residents only. Back to the Office is an Introducer Appointed Representative of Snap Finance Limited, which is authorised and regulated by the Financial Conduct Authority (FRN 741813). Snap Finance Limited is the lender.

We accept all of these. Choose the one you want at checkout.

  • American Express
  • Apple Pay
  • Google Pay
  • Maestro
  • Mastercard
  • PayPal
  • Shop Pay
  • Visa
  • Express checkout Shop Pay, Apple Pay, Google Pay and PayPal
  • Card Visa, Mastercard, American Express and Maestro
  • Pay later Snap Finance, Klarna, Clearpay, PayPal Pay in 3 and more
Go to checkout with this item

Secure checkout. You can add a discount code or gift card on the next page.

Price drop alert

D-Link 24-port Gigabit PoE Smart Managed Switch with 4x 10G SFP+, 370Watts
Now £345.99

We'll email you if the price of this item drops in the next 90 days.

By setting an alert you agree to receive price drop emails from Back to the Office for this item and others you view. No newsletters. Unsubscribe at any time. Privacy policy

Alert set

We'll email if the price of D-Link 24-port Gigabit PoE Smart Managed Switch with 4x 10G SFP+, 370Watts drops.

  • 14-day returns Details
  • UK manufacturer warranty Details
  • Price Match Promise Details
  • Rated 4.9/5 by customers on Trustpilot & Feefo Read reviews
OverviewSpecificationsManuals & downloadsReviews Delivery & returns

Overview

  • 24 x 10/100/1000BASE-T PoE ports
  • 4 x 10G SFP+ ports
  • Lite L3 Static Routing
  • Advanced security features, IMPB, 802.1X Authentication
  • 370W PoE budget (802.3af/at)
  • Dual Image & Configuration
  • Supports STP/RSTP/MSTP
  • Full CLI
  • QoS Enablement
  • 11 Web Languages

Power & Value
The D-Link DGS-1250 Series Smart Managed Switches deliver real value as an Enterprise Access and Small-to-Medium Business (SMB) Access/Aggregation solution. They provide a range of physical interfaces (including a Console Port w/full CLI), multiple management interfaces, 11 Web languages, QoS enablement, and Advanced Layer-2 w/Lite Layer-3 features.

The DGS-1250 Series switches support 24 or 48 x 10/100/1000BASE-T ports, with each switch also supporting an additional 4 x 10G SFP+ ports for optical connections using multimode or single-mode SFP transceivers – enabling real network horsepower at a value price.

Easy Maintenance, Less Downtime
The DGS-1250 Series supports Dual Image and Dual Configuration functionality, as well as a Console Port, all of which make it easier to configure, troubleshoot, and make other changes without interfering with network operation, while full Command Line Interface (CLI) functionality enables remote configuration, without the need for the Internet. And if a network issue ever does occur, the supported Spanning Tree Protocols (STP/RSTP/MSTP) help keep things running without interruptions or downtime.

Automatic Configuration
The DGS-1250 Series supports Auto Voice VLAN and Surveillance Mode, which allow Voice and Video traffic to be automatically identified and handled differently from regular network traffic. Auto Voice VLAN detects Voice over IP (VoIP) traffic and automatically segments it from the rest of the network, increasing security and allowing Quality of Service (QoS) to be applied.

High PoE Budget (370W)
The DGS-1250 series offers Power-over-Ethernet (PoE), which simplifies deployment with IP cameras, VoIP phones, Wireless Access Points, and other powered devices. Using the switch’s management interface, an administrator can control various PoE functions, such as remotely rebooting Cameras or Access Points, from anywhere on the network, including over the Internet. All PoE models support the IEEE 802.3af and 802.3at standards, and each PoE power budget varies per model.

Extensive Management and Advanced Features
The DGS-1250 Series comes with IGMP snooping, Port Mirroring, Spanning Tree Protocol (STP), and Link Aggregation Control Protocol (LACP). The IEEE 802.3x Flow Control function allows servers to directly connect to the switch for fast, reliable data transfers. The series also supports advanced features such as Static Routing, which allows for communication between different user groups in different VLAN segments in a network.

Management Versatility
The DGS-1250 Series comes with the D-Link Network Assistant (DNA) utility so admins can remotely control their network to the port level. DNA allows customers to easily discover multiple D-Link Smart Managed Switches within the same L2 network segment and display them onscreen for instant access.

Specifications

Management features

MIB supportRFC2893, RFC4213, RFC4291, RFC2464, RFC2462, RFC4862, RFC2461, RFC4861, RFC2573, RFC1321, RFC2284, RFC2865, RFC2716, RFC3580, RFC826, RFC2463, RFC4443, RFC792, RFC793, RFC768, RFC791, RFC2389, RFC4113, RFC4022, RFC2618, RFC2674, RFC1398, RFC1643, RFC1650, RFC2358, RFC2665, RFC2021, RFC271, RFC1757, RFC2819, RFC1442, RFC1901, RFC1902, RFC1903, RFC1904, RFC1905, RFC1906, RFC1907, RFC1908, RFC2578, RFC3418, RFC2573, RFC2575, RFC2576, RFC1212, RFC1213, RFC1215, RFC1493, RFC1157, RFC2620,
System event logYes
ARP inspectionYes
Configuring Location Settings (CLI)Yes
Web-based managementYes
Quality of Service (QoS) supportYes
Switch layerL3
Switch typeManaged

Ports & interfaces

Console portRJ-45
SFP+ module slots quantity4
Basic switching RJ-45 Ethernet ports typeGigabit Ethernet (10/100/1000)
Basic switching RJ-45 Ethernet ports quantity24
Show all 90 specificationsShow fewer specifications

Network

Number of VLANs4094
Virtual LAN featuresVoice VLAN
VLAN supportYes
Link aggregationYes
Flow control supportYes
Auto MDI/MDI-XYes
Broadcast storm controlYes
Spanning tree protocolYes
Head-of-line (HOL) blockingYes
Full duplexYes
Port mirroringYes
Cable types supportedCat5, Cat5e
Copper ethernet cabling technology10BASE-T, 100BASE-TX, 1000BASE-T
10G supportYes
Networking standardsIEEE 802.3af, IEEE 802.3at

Optical fiber

Fiber ethernet cabling technology100BASE-FX, 1000BASE-LHX, 1000BASE-X, 1000BASE‑LX, 1000BASE‑SX, 1000BASE‑ZX

Data transmission

Packet buffer memory12 MB
Jumbo frames12000
Jumbo frames supportYes
Number of static routes124
Static routeYes
Store-and-forwardYes
Forwarding rate95.24 Mpps
Switching capacity128 Gbit/s
MAC address table16000 entries

Security

Loop protectionYes
Security algorithmsEAP, LEAP, MD5, PEAP, SSH, SSL/TLS, TTLS
Queue scheduling algorithmsWeighted Round Robin (WRR)
IP-MAC-Port bindingYes
IGMP snoopingYes
Access Control List (ACL) rules768
Access Control List (ACL)Yes
DHCP featuresDHCP server, DHCP snooping

Multicast features

Multicast supportYes

Design

Electromagnetic compatibilityCE A, VCCI A, FCC A, IC, BSMI
LED indicatorsActivity, Link, Power, Speed
Product colourBlack
Rack mountingYes

Performance

Mean time between failures (MTBF)463430.16 h
Firmware upgradeableYes
Noise level50.8 dB
Flash memory64 MB
Internal memory2048 MB
Memory typeDDR3-SDRAM

Power

Power consumption (max)455.1 W
AC input frequency50 - 60 Hz
AC input voltage100 - 240 V
Power supply includedYes

Power over Ethernet (PoE)

Total Power over Ethernet (PoE) budget370 W
Power over Ethernet (PoE) power per port15.4 W
Power over Ethernet (PoE) ports quantity24
Power over Ethernet (PoE)Yes

Operational conditions

Heat dissipation1551.891 BTU/h
Storage relative humidity (H-H)0 - 95%
Operating relative humidity (H-H)0 - 95%
Storage temperature (T-T)-20 - 70 °C
Operating temperature (T-T)-5 - 50 °C

Weight & dimensions

Weight3.46 kg
Height44 mm
Depth250 mm
Width440 mm

Technical details

Shipping (inner) case height42.8 cm
Shipping (inner) case width47.8 cm
Shipping (inner) case length58.5 cm
Shipping (inner) case net weight19.3 kg
Products per shipping (inner) case5 pc(s)
Pallet gross weight (air)426 kg
Master (outer) cases per pallet (air)16 pc(s)
Products per pallet (air)80 pc(s)
Pallet gross length110 cm
Pallet gross width120 cm
Pallet height (air)184.7 cm
Pallet gross weight (sea)426 kg
Master (outer) cases per pallet (sea)16 pc(s)
Products per pallet (sea)80 pc(s)
Pallet height (sea)184.7 cm
Shipping (inner) case gross weight25.5 kg

Certificates

CertificationCB, UL, BSMI, CCC

Manuals & downloads

  • Image of packaging (PDF)
  • Eu declaration of conformity (PDF)
  • Leaflet (PDF)
  • Web ui reference guide (PDF)
  • Hardware installation guide (PDF)
  • Manual pdf (PDF)
  • Manual pdf (PDF)

Customer reviews

Delivery & returns

Delivery

  • FREE standard delivery on orders over £50, otherwise £4.95 (3–5 working days).
  • Express delivery £9.99 (1–3 working days) on selected products, UK mainland.
  • PlayStation and Arozzi products use a 5–7 working-day service.
  • Orders are processed within 24 hours, Monday to Friday excluding bank holidays. All deliveries must be signed for.

Returns

  • Changed your mind? Tell us within 14 days of receiving your item, then return it within a further 14 days, unused and in its original packaging. A minimum £9.99 collection fee applies.
  • Faulty or damaged on arrival? Contact us within 48 hours of delivery.
  • Custom-built PCs can only be returned if faulty. Opened headphones, earphones and AirPods can't be returned for hygiene reasons.

Full delivery information · Full returns policy

Similar products

Goes with this

D-Link 24-port Gigabit PoE Smart Managed Switch with 4x 10G SFP+, 370Watts £345.99

Information

  • About us
  • Contact us
  • Our Reviews
  • Shipping Policy
  • Terms & Conditions
  • Privacy & Cookie Policy
  • Fraud Prevention & Security
  • Returns & Refunds
  • Money Wellness (Debt Advice)
  • For Business

Support

  • Delivery Information
  • Manufacturer Warranty
  • Price Match Promise
  • Snap Finance
  • Klarna
  • ClearPay
  • Careers
  • Complaints
  • Vulnerable Customer Policy & TCF
  • Ink & Toner Finder
  • Buying Guides
  • Gaming PC Gift Finder
  • Gaming PC Guide for Parents

My Account

  • Sign In
  • Register
  • Track your order
  • Returns
  • Shop By Brand
  • Affiliate Program
  • FAQ

Contact Us

Head Office:
71-75 Shelton Street, Covent Garden, London, United Kingdom, WC2H 9JQ

Email: hello@backtotheoffice.co.uk

Track your order

Follow Us:

Opens external website in a new window. Opens external website in a new window. Opens external website in a new window.
Visa Mastercard American Express PayPal Clearpay
Klarna Google Pay Apple Pay Snap Finance Float

Snap Finance: Back to the Office is an Introducer Appointed Representative of Snap Finance Limited which is authorised and regulated by the Financial Conduct Authority (Firm reference number 741813). Snap Finance Limited act as the lender.

Pay later with Klarna. Borrowing more than you can afford or paying late may negatively impact your financial status and ability to obtain credit. Subject to status. Ts&Cs and late fees apply. Klarna.com/uk/terms-and-conditions

Clearpay: Clearpay credit subject to status. Ensure you can make repayments on time. You must be 18+ and a permanent UK resident (excl Channel Islands). Clearpay charges a £6 late fee for each late instalment and a further £6 if it’s still unpaid 7 days later. Late fees are capped at £6 for orders under £24 and the lower of £24 or 25% of the order value for orders over £24. Missed payments may affect your future access to credit and your details may be passed onto a debt collection agency working on Clearpay's behalf. T&Cs apply Clearpay.co.uk/terms

Float: Float charges no interest or fees on your instalment plan. Your credit card issuer’s standard terms and conditions, including interest on outstanding balances, will still apply. Please make sure you can comfortably afford each monthly instalment. Float is the trading name of Float Technologies Limited, registered in England and Wales (Company Number: 16558482). Float is not authorised and regulated by the Financial Conduct Authority.

© 2026 Back to the Office.

Your basket

    Your basket is empty

    Start shopping

      Subtotal

      Delivery and any discount codes are calculated at checkout.

      Checkout securely
      View basket