D-Link 12-Port L2 Managed Switch Switch with 8 x 10/100/1000BaseT(X) & 4 x 100/1000BaseSFP
Spread the cost with Klarna, Clearpay, PayPal, Float or SnapFrom 3 interest-free payments of £273.33 See options
Credit subject to status. 18+, UK residents only. See each provider for terms.
Out of stock
FREE delivery
Express £9.99
Couldn't load pickup availability
- 14-day returns Details
- UK manufacturer warranty Details
- Price Match Promise Details
- Rated 4.9/5 by customers on Trustpilot & Feefo Read reviews
Available now
Overview
- 8 x 100/1000BaseT ports, 4 x 100/1000BaseSFP slots
- High availability
- Easy-to-control management interfaces and security
- Withstands extreme temperatures
- Certified for vibration, shock, free-fall, EMC
Managed Customization
Features user management interfaces, including an industrial-like CLI, and WEB-based management, the DIS-300G-12SW is easy to manage and provides the security and controls to guard and shape your network needs.
Gigabit Connectivity with SFP slots
Designed with 8 x 100/1000BaseT ports and 4 x 100/1000Base SFP to suit a range of devices and network layouts.
Officially Certified
Certifications for vibration, shock, free-fall, and electromagnetic compatibility to maximise network uptime in a variety of deployment environments, including smart city surveillance, factory automation, and outdoor wireless networks.
Withstands Extreme Temperatures
Operates effortlessly in a range of industrial and harsh environments in temperatures from -40°C to +75°C, and can cold start from -40°C.
Strong Build
The tough housing has been created to keep your network protected and reliably rugged. That’s why every DIS-switch comes with a 5-year D-Link warranty.
High Availability
Rapid ring failover recovery time of < 20ms, with even faster PROFINET speeds available at project request.
Fast Deployment
For instant installation it features a snap-to-DIN-rail clip, and also supports wall mounting.
Fanless Design
With no moving parts inside to reduce downtime and maintenance call outs, the rugged housing has been optimised for the transfer of heat.
Discrete Size
Small but mighty. To make the most of cabinet space, it measures: 61 x 154 x 109 mm.
Specifications
Management features
| MIB support | RFC 1757 RMON 1,2,3,9; RFC 2674 Q MIB RFC‑1213 MIB‑II; RFC‑1493 MIB; RFC 2233 IF MIB |
|---|---|
| System event log | Yes |
| Traffic shaping | Yes |
| Web-based management | Yes |
| Quality of Service (QoS) support | Yes |
| Switch layer | L2 |
| Switch type | Managed |
Ports & interfaces
| Fiber optic connector | LC |
|---|---|
| SFP module slots quantity | 4 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| Basic switching RJ-45 Ethernet ports quantity | 8 |
Show all 68 specificationsShow fewer specifications
Network
| Number of VLANs | 1024 |
|---|---|
| Virtual LAN features | Tagged VLAN, Protocol-based VLAN, Port-based VLAN |
| VLAN support | Yes |
| Link aggregation | Yes |
| Flow control support | Yes |
| Auto MDI/MDI-X | Yes |
| Auto-negotiation | Yes |
| Broadcast storm control | Yes |
| Spanning tree protocol | Yes |
| Full duplex | Yes |
| 10G support | No |
| Networking standards | IEEE 802.1D, IEEE 802.1ab, IEEE 802.1ad, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.3ad, IEEE 802.3x |
Data transmission
| Jumbo frames | 9000 |
|---|---|
| Jumbo frames support | Yes |
| Store-and-forward | Yes |
| MAC address table | 8000 entries |
Security
| Security algorithms | HTTPS, SNMP, SNMPv3, SSH |
|---|---|
| Authentication type | IEEE 802.1x, RADIUS |
| Queue scheduling algorithms | Weighted Round Robin (WRR) |
| DHCP features | DHCP server, DHCP snooping, DHCP relay, DHCP client |
Multicast features
| Multicast support | Yes |
|---|
Design
| Electromagnetic compatibility | FCC 15, EN 61000‑6‑2, EN 61000‑6‑4, EN 61000‑4‑2, ‑3, ‑4, ‑5, ‑6 |
|---|---|
| Wall mountable | Yes |
| International Protection (IP) code | IP30 |
| DIN rail mounting | Yes |
| LED indicators | LAN, Status |
| Product colour | Black |
| Rack mounting | No |
Performance
| Firmware upgradeable | Yes |
|---|
Power
| Power protection features | Over current, Reverse polarity |
|---|---|
| Power consumption (max) | 17 W |
| DC input voltage | 12 - 58 V |
Power over Ethernet (PoE)
| Power over Ethernet (PoE) | No |
|---|
Operational conditions
| Operating relative humidity (H-H) | 5 - 95% |
|---|---|
| Storage temperature (T-T) | -40 - 85 °C |
| Operating temperature (T-T) | -40 - 75 °C |
Weight & dimensions
| Weight | 1.09 kg |
|---|---|
| Height | 109 mm |
| Depth | 154 mm |
| Width | 61 mm |
Technical details
| Shipping (inner) case height | 27 cm |
|---|---|
| Shipping (inner) case width | 41 cm |
| Shipping (inner) case length | 60 cm |
| Shipping (inner) case net weight | 15.3 kg |
| Products per shipping (inner) case | 10 pc(s) |
| Pallet gross weight (air) | 346.7 kg |
| Master (outer) cases per pallet (air) | 20 pc(s) |
| Products per pallet (air) | 200 pc(s) |
| Pallet gross length | 120 cm |
| Pallet gross width | 110 cm |
| Pallet height (air) | 148.5 cm |
| Pallet gross weight (sea) | 478.6 kg |
| Master (outer) cases per pallet (sea) | 28 pc(s) |
| Products per pallet (sea) | 280 pc(s) |
| Pallet height (sea) | 2.02 m |
| Shipping (inner) case gross weight | 16.5 kg |
Certificates
| Certification | IEC60068‑2‑6, IEC60068‑2‑27, IEC60068‑2‑32, UL 60950‑1, CE, FCC, RoHS, WEEE |
|---|
Manuals & downloads
Customer reviews
Delivery & returns
Delivery
- FREE standard delivery on orders over £50, otherwise £4.95 (3–5 working days).
- Express delivery £9.99 (1–3 working days) on selected products, UK mainland.
- PlayStation and Arozzi products use a 5–7 working-day service.
- Orders are processed within 24 hours, Monday to Friday excluding bank holidays. All deliveries must be signed for.
Returns
- Changed your mind? Tell us within 14 days of receiving your item, then return it within a further 14 days, unused and in its original packaging. A minimum £9.99 collection fee applies.
- Faulty or damaged on arrival? Contact us within 48 hours of delivery.
- Custom-built PCs can only be returned if faulty. Opened headphones, earphones and AirPods can't be returned for hygiene reasons.