Menu
  • Build your PC in 3D
  • PC Gift Finder
  • Ink Finder
  • Outlet deals

Shop by category

  • Laptops
    • Shop all Laptops
    • Laptops by type
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
      • 2 in 1 Laptops
      • Business Laptops
      • Education Laptops
      • Chromebooks
      • Slim Laptops
      • Refurbished Laptops
    • Popular Searches
      • Laptops under £250
      • Laptops under £500
      • Laptops under £1000
      • 15.6 Inch Laptops
      • 14 Inch Laptops
      • 11.6 Inch Laptops
    • Laptops by brand
      • Microsoft
      • Samsung
      • Apple
      • Lenovo
      • HP
      • ASUS
      • Acer
      • Dell
    • Laptop accessories
      • Bags & Cases
      • Docking Stations
      • Laptop RAM
      • Keyboards
      • Mice
      • Software
      • USB Flash Drives
      • Headsets & Headphones
      • Webcams
      • Privacy Filters
  • PCs
    • Shop all PCs
    • Desktop PCs
      • View All PCs
      • The Gaming Club PCs
      • Gaming PCs
      • Barebone PCs
      • Windows PCs
      • All-In-One PCs
      • iMacs / Mac Minis
    • Custom Build PCs
      • Build a Gaming PC
      • £500 - £999 Gaming PCs
      • £1000 - £1999 Gaming PCs
      • £2000+ Gaming PCs
    • Gaming PCs
      • View All Gaming PCs
    • PC Accessories
      • View all Accessories
      • Storage
      • Keyboards
      • Mice
      • Mouse Mats
      • Headsets
      • Gaming Headsets
      • Webcams
      • Speakers
      • Software
  • Components
    • Components
      • View All Components
    • Graphics Cards
      • View All Graphics Cards
      • NVIDIA Graphics Cards
      • AMD Graphics Cards
      • Intel Graphics Cards
      • NVIDIA 5090 Graphics Cards
      • NVIDIA 5080 Graphics Cards
      • NVIDIA 5070 Graphics Cards
    • Storage
      • View All Storage
      • SSD Drives
      • M.2 SSDs
      • Internal Solid State Drives
      • External Solid State Drives
    • Cooling
      • View All Cooling
      • Liquid Cooling
      • Air Coolers
      • Case Fans
    • Processors
      • View All Processors
      • Intel Processors
      • AMD Processors
    • Memory
      • View All Memory
      • DDR5 RAM
      • DDR4 RAM
      • DDR3 RAM
    • Motherboards
      • View All Motherboards
      • Intel Motherboards
      • AMD Motherboards
    • Power Supplies
      • View All Power Supplies
      • 300W-650W
      • 750W
      • 850W
      • 1000W+
  • Computing
    • Monitors
      • View all Monitors
      • View All Monitors
      • 4K Monitors
      • Gaming Monitors
      • 24" Monitors
      • 27" Monitors
      • 32" Monitors
      • 34" Monitors
      • 35" + Monitors
      • QHD Monitors
      • Ultra Wide Monitors
      • Monitor Mounts & Arms
    • Desktop PCs
      • View All Desktop PCs
      • Gaming PCs
      • Custom Built PCs
      • Apple iMac & Mac Minis
    • Laptops
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
    • Networking
      • View All Networking
      • Whole Home Mesh Wi-Fi
      • Wifi Routers & Modems
      • Network Switches
      • Wireless Access Points
      • Wifi Range Extenders
      • Network Cards
    • Printers & Scanners
      • View All Printers
      • All-In-One Printers
      • Laser Printers
      • Inkjet Printer
      • Label Printers
      • Scanners
    • Ink & Printer Accessories
      • Ink Cartridges
      • Toner Cartridges
      • Paper & Card
      • Shredders
    • Audio
      • Speakers
    • PC Cases
      • View All Cases
      • Full Tower Cases
      • Mid Tower Cases
      • Mini ITX Cases
      • Micro ATX Cases
  • TV & Audio
    • Shop all TV & Audio
    • Televisions
      • View all Televisions
      • View all TVs
      • 55" or more TVs
      • 48" - 54" TVs
      • 42" - 47" TVs
      • 32" - 41" TVs
      • Smaller TVs 32" and Below
      • 4K Ultra HD TVs
    • TV accessories
      • Smart TV Boxes
      • Smart TV Dongles
      • TV stands
      • Remote controls
    • Blu-Ray and Home Cinema
      • Home cinema systems and soundbars
    • Projectors
      • View all Projectors
      • 4K Projectors
      • HD Projectors
    • Speakers & Soundbars
      • View all Speakers
      • Soundbars
      • Portable bluetooth speakers
    • Headphones
      • View all headphones
      • In-ear headphones
      • Over-ear headphones
      • Wired headphones
      • Wireless and bluetooth headphones
      • Sports headphones
  • Gaming
    • Shop all Gaming
    • Gaming PCs and Laptops
      • View all Gaming PCs
      • View all Gaming Laptops
    • Gaming Monitors
      • View all Gaming Monitors
      • 144 HZ + Monitors
      • 4K Monitors
      • Curved Monitors
      • Ultra Wide Monitors
    • Build Your Own Gaming PC
      • Start from Scratch
    • Simulation
      • Flight Simulation
      • Racing Simulation
      • VR Headsets
    • Gaming Accessories
      • View all Gaming Accessories
      • Gaming Chairs
      • Gaming Desks
      • Gaming Keyboards
      • Gaming Mice
      • Gaming Headsets
      • Controllers
      • Gaming Routers
      • Microphones
      • Speakers
      • Streaming
      • Mouse Pads
    • Gaming Components
      • View all Components
      • Graphics Cards
      • Processors
      • Motherboards
      • Memory
      • Cases
      • Cooling
      • Power Supplies
      • Laptop RAM
      • Storage
    • Console Gaming
      • View all Console Gaming
      • Console Storage
      • Xbox Consoles
      • Xbox Controllers
      • Playstation Consoles
      • Playstation Controllers
      • Nintendo Switch Consoles
      • Nintendo Switch Controllers
    • Games
      • PS5 games
      • Xbox games
      • Nintendo Switch games
  • Phones & Tablets
    • Shop all Phones & Tablets
    • Tablets
      • View all Tablets
      • Samsung Tablets
      • Lenovo Tablets
      • Tablet Cases
    • iPads
      • View all iPads
    • Smart Phones
      • View all Smart Phones
      • View all Mobile Phones
      • Mobile Phones (Non-Smart)
      • Apple iPhones
      • Samsung Phones
    • Accessories
      • View all Phone Cases
      • iPhone Cases
      • Samsung Phone Cases
      • Car Chargers
      • Power Banks
      • Mains Chargers
      • Charging Cables
      • Screen Protectors
  • Home & Lifestyle
    • Shop all Home & Lifestyle
    • Smart Home
      • View all Smart Home
      • Video Doorbells
      • Indoor Cameras
      • Outdoor Smart Cameras
      • Smart Lighting
    • Surveillance and Security
      • View all Security Cameras
      • NVR/DVRs
    • Health and Wellbeing
      • View all Health & Wellbeing
      • E-Scooters
      • Smart Watches
      • Activity Trackers
      • Coffee Machines
      • Coffee Grinders
      • Coffee Maker Parts & Accessories
    • Home Office
      • View all Home Office
      • Home Office Desks
      • Home Office Chairs
  • Ink Finder
  • Outlet
  • Sign in
  • Checkout
Back to the Office

Sign in Checkout
  • Laptops
    • Laptops by type
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
      • 2 in 1 Laptops
      • Business Laptops
      • Education Laptops
      • Chromebooks
      • Slim Laptops
      • Refurbished Laptops
    • Popular Searches
      • Laptops under £250
      • Laptops under £500
      • Laptops under £1000
      • 15.6 Inch Laptops
      • 14 Inch Laptops
      • 11.6 Inch Laptops
    • Laptops by brand
      • Microsoft
      • Samsung
      • Apple
      • Lenovo
      • HP
      • ASUS
      • Acer
      • Dell
    • Laptop accessories
      • Bags & Cases
      • Docking Stations
      • Laptop RAM
      • Keyboards
      • Mice
      • Software
      • USB Flash Drives
      • Headsets & Headphones
      • Webcams
      • Privacy Filters
  • PCs
    • Desktop PCs
      • View All PCs
      • The Gaming Club PCs
      • Gaming PCs
      • Barebone PCs
      • Windows PCs
      • All-In-One PCs
      • iMacs / Mac Minis
    • Custom Build PCs
      • Build a Gaming PC
      • £500 - £999 Gaming PCs
      • £1000 - £1999 Gaming PCs
      • £2000+ Gaming PCs
    • Gaming PCs
      • View All Gaming PCs
    • PC Accessories
      • View all Accessories
      • Storage
      • Keyboards
      • Mice
      • Mouse Mats
      • Headsets
      • Gaming Headsets
      • Webcams
      • Speakers
      • Software
  • Components
    • Components
      • View All Components
    • Graphics Cards
      • View All Graphics Cards
      • NVIDIA Graphics Cards
      • AMD Graphics Cards
      • Intel Graphics Cards
      • NVIDIA 5090 Graphics Cards
      • NVIDIA 5080 Graphics Cards
      • NVIDIA 5070 Graphics Cards
    • Storage
      • View All Storage
      • SSD Drives
      • M.2 SSDs
      • Internal Solid State Drives
      • External Solid State Drives
    • Cooling
      • View All Cooling
      • Liquid Cooling
      • Air Coolers
      • Case Fans
    • Processors
      • View All Processors
      • Intel Processors
      • AMD Processors
    • Memory
      • View All Memory
      • DDR5 RAM
      • DDR4 RAM
      • DDR3 RAM
    • Motherboards
      • View All Motherboards
      • Intel Motherboards
      • AMD Motherboards
    • Power Supplies
      • View All Power Supplies
      • 300W-650W
      • 750W
      • 850W
      • 1000W+
  • Computing
    • Monitors
      • View All Monitors
      • 4K Monitors
      • Gaming Monitors
      • 24" Monitors
      • 27" Monitors
      • 32" Monitors
      • 34" Monitors
      • 35" + Monitors
      • QHD Monitors
      • Ultra Wide Monitors
      • Monitor Mounts & Arms
    • Desktop PCs
      • View All Desktop PCs
      • Gaming PCs
      • Custom Built PCs
      • Apple iMac & Mac Minis
    • Laptops
      • View All Laptops
      • Gaming Laptops
      • Apple Macbooks
    • Networking
      • View All Networking
      • Whole Home Mesh Wi-Fi
      • Wifi Routers & Modems
      • Network Switches
      • Wireless Access Points
      • Wifi Range Extenders
      • Network Cards
    • Printers & Scanners
      • View All Printers
      • All-In-One Printers
      • Laser Printers
      • Inkjet Printer
      • Label Printers
      • Scanners
    • Ink & Printer Accessories
      • Ink Cartridges
      • Toner Cartridges
      • Paper & Card
      • Shredders
    • Audio
      • Speakers
    • PC Cases
      • View All Cases
      • Full Tower Cases
      • Mid Tower Cases
      • Mini ITX Cases
      • Micro ATX Cases
  • TV & Audio
    • Televisions
      • View all TVs
      • 55" or more TVs
      • 48" - 54" TVs
      • 42" - 47" TVs
      • 32" - 41" TVs
      • Smaller TVs 32" and Below
      • 4K Ultra HD TVs
    • TV accessories
      • Smart TV Boxes
      • Smart TV Dongles
      • TV stands
      • Remote controls
    • Blu-Ray and Home Cinema
      • Home cinema systems and soundbars
    • Projectors
      • View all Projectors
      • 4K Projectors
      • HD Projectors
    • Speakers & Soundbars
      • View all Speakers
      • Soundbars
      • Portable bluetooth speakers
    • Headphones
      • View all headphones
      • In-ear headphones
      • Over-ear headphones
      • Wired headphones
      • Wireless and bluetooth headphones
      • Sports headphones
  • Gaming
    • Gaming PCs and Laptops
      • View all Gaming PCs
      • View all Gaming Laptops
    • Gaming Monitors
      • View all Gaming Monitors
      • 144 HZ + Monitors
      • 4K Monitors
      • Curved Monitors
      • Ultra Wide Monitors
    • Build Your Own Gaming PC
      • Start from Scratch
    • Simulation
      • Flight Simulation
      • Racing Simulation
      • VR Headsets
    • Gaming Accessories
      • View all Gaming Accessories
      • Gaming Chairs
      • Gaming Desks
      • Gaming Keyboards
      • Gaming Mice
      • Gaming Headsets
      • Controllers
      • Gaming Routers
      • Microphones
      • Speakers
      • Streaming
      • Mouse Pads
    • Gaming Components
      • View all Components
      • Graphics Cards
      • Processors
      • Motherboards
      • Memory
      • Cases
      • Cooling
      • Power Supplies
      • Laptop RAM
      • Storage
    • Console Gaming
      • View all Console Gaming
      • Console Storage
      • Xbox Consoles
      • Xbox Controllers
      • Playstation Consoles
      • Playstation Controllers
      • Nintendo Switch Consoles
      • Nintendo Switch Controllers
    • Games
      • PS5 games
      • Xbox games
      • Nintendo Switch games
  • Phones & Tablets
    • Tablets
      • View all Tablets
      • Samsung Tablets
      • Lenovo Tablets
      • Tablet Cases
    • iPads
      • View all iPads
    • Smart Phones
      • View all Mobile Phones
      • Mobile Phones (Non-Smart)
      • Apple iPhones
      • Samsung Phones
    • Accessories
      • View all Phone Cases
      • iPhone Cases
      • Samsung Phone Cases
      • Car Chargers
      • Power Banks
      • Mains Chargers
      • Charging Cables
      • Screen Protectors
  • Home & Lifestyle
    • Smart Home
      • View all Smart Home
      • Video Doorbells
      • Indoor Cameras
      • Outdoor Smart Cameras
      • Smart Lighting
    • Surveillance and Security
      • View all Security Cameras
      • NVR/DVRs
    • Health and Wellbeing
      • View all Health & Wellbeing
      • E-Scooters
      • Smart Watches
      • Activity Trackers
      • Coffee Machines
      • Coffee Grinders
      • Coffee Maker Parts & Accessories
    • Home Office
      • View all Home Office
      • Home Office Desks
      • Home Office Chairs
  • Ink Finder
  • Outlet
Home D-Link 12-port 10GBASE-T, 2-port SFP+ and 2-port
D-Link 12-port 10GBASE-T, 2-port SFP+ and 2-port 10GBASE-T/SFP+ Multi-Gigabit Smart Managed Switch
D-Link 12-port 10GBASE-T, 2-port SFP+ and 2-port 10GBASE-T/SFP+ Multi-Gigabit Smart Managed Switch - image 2
1 / 2
D-Link 12-port 10GBASE-T, 2-port SFP+ and 2-port 10GBASE-T/SFP+ Multi-Gigabit Smart Managed Switch
D-Link 12-port 10GBASE-T, 2-port SFP+ and 2-port 10GBASE-T/SFP+ Multi-Gigabit Smart Managed Switch - image 2
D-Link 12-port 10GBASE-T, 2-port SFP+ and 2-port 10GBASE-T/SFP+ Multi-Gigabit Smart Managed Switch
D-Link 12-port 10GBASE-T, 2-port SFP+ and 2-port 10GBASE-T/SFP+ Multi-Gigabit Smart Managed Switch - image 2

D-Link 12-port 10GBASE-T, 2-port SFP+ and 2-port 10GBASE-T/SFP+ Multi-Gigabit Smart Managed Switch

D-Link · MPN: DXS-1210-16TC
Sale!
from £1,631.99
/per
inc. VAT
Spread the cost with Klarna, PayPal, Float or SnapFrom 3 interest-free payments of £543.99 See options

Credit subject to status. 18+, UK residents only. See each provider for terms.

Out of stock

FREE delivery

Express £9.99

 
 
More payment options Snap Finance Spread the cost up to 4 years
Snap Finance

Spread the cost up to 4 years with Snap Finance

Pay £1 deposit · Pay in 4 available · Decision in minutes

Soft check, won't affect your credit score. Representative 29.9% APR. Choose Snap Finance at checkout.

How Snap Finance works

Credit subject to status. 18+, UK residents only. Back to the Office is an Introducer Appointed Representative of Snap Finance Limited, which is authorised and regulated by the Financial Conduct Authority (FRN 741813). Snap Finance Limited is the lender.

We accept all of these. Choose the one you want at checkout.

  • American Express
  • Apple Pay
  • Google Pay
  • Maestro
  • Mastercard
  • PayPal
  • Shop Pay
  • Visa
  • Express checkout Shop Pay, Apple Pay, Google Pay and PayPal
  • Card Visa, Mastercard, American Express and Maestro
  • Pay later Snap Finance, Klarna, Clearpay, PayPal Pay in 3 and more
Go to checkout with this item

Secure checkout. You can add a discount code or gift card on the next page.

  • 14-day returns Details
  • UK manufacturer warranty Details
  • Price Match Promise Details
  • Rated 4.9/5 by customers on Trustpilot & Feefo Read reviews

Available now

    OverviewSpecificationsManuals & downloadsReviews Delivery & returns

    Overview

    • Managed L2 Web-based management
    • Quality of Service (QoS) support
    • Basic switching RJ-45 Ethernet ports quantity: 12
    • 10G support 10GBASE-T, 100BASE-TX, 1000BASE-T
    • MAC address table: 16000 entries Switching capacity: 320 Gbit/s
    • 256 Access Control List (ACL)
    • Rack mounting

    Energy efficient

    By incorporating D-Link Green technology, this series of switches is capable of saving power without sacrificing operational performance or functionality. The switches feature built-in smart fans with internal heat sensors, that monitor and detect temperature changes and react accordingly by utilizing different fan speeds for different temperatures. At lower temperatures, the fans will run slower, reducing the switch's power consumption and noise. Link status drastically reduces power consumption by automatically putting ports without a link into a sleep mode. The DXS-1210 takes the approach to green IT one step further by incorporating a special chipset with advanced silicon technology for efficient use of energy.

    Extensive management and Layer 2 features

    The DXS-1210 comes with a complete line-up of L2 features, includes port mirroring, Spanning Tree Protocol (STP), and Link Aggregation Control Protocol (LACP). Network maintenance features include loopback detection and cable diagnostics. Loopback detection significantly speeds up troubleshooting by automatically detecting and shutting down difficult to diagnose switching loops. The cable diagnostic feature, designed primarily for administrators and customer service representatives, determines the cable quality and quickly discovers errors, allowing hassle-free diagnostics and maintenance.

    Quality of service and bandwidth control

    The DXS-1210 supports Auto Surveillance VLAN (ASV) and Auto Voice VLAN, which are suited for VoIP and video surveillance deployments. Auto Surveillance VLAN is a technology, that consolidates data and surveillance video transmission through a single DXS-1210 switch, thus sparing businesses the expense of dedicated hardware and facilities. ASV also ensures quality real-time video monitoring and control without compromising the transmission of conventional network data. Auto Voice VLAN technology enhances the VoIP service by automatically placing voice traffic from IP phones to a designated VLAN. With a prioritized and segmented VLAN, this feature guarantees quality and security of VoIP traffic. The Differentiated Service Code Point (DSCP) markings on Ethernet packets enable different levels of service to be assigned to network traffic. As a result, these voice and video packets take precedence over other packets. In addition, with bandwidth control, network administrators can reserve bandwidth for important functions, that require higher priority or more bandwidth.

    Secure your network

    D-Link's innovative Safeguard Engine protects the switches against traffic flooding, caused by malicious attacks. The DXS-1210 supports 802.1X port-based and host-based authentication, allowing the network to be authenticated through external RADIUS servers. The Access Control List (ACL) feature enhances network security and helps to protect the internal IT network. The DXS-1210 also features Address Resolution Protocol (ARP) spoofing prevention, which protects from attacks on the network that may allow an intruder to sniff data frames, modify traffic, or bring traffic to a halt altogether by sending fake ARP messages. To prevent ARP spoofing attacks, the switch uses packet control ACLs to block invalid packets, that contain fake ARP messages. For added security, the DHCP server screening feature filters DHCP replies on unauthorized ports to prevent them from being assigned an IP address.

    Specifications

    Management features

    MIB supportRFC 783, RFC 951, RFC 1157, RFC 1213, RFC 1215, RFC 1350, RFC 1493, RFC 1769, RFC 1542, RFC 1901, RFC 1907, RFC 1908, RFC 2131, RFC 2138, RFC 2139, RFC 2233, RFC-2246, RFC 2475, RFC 2570, RFC 2575, RFC 2598, RFC 2618, RFC 2819, RFC 2865, RFC 3164, RFC 3195, RFC 3411-17
    System event logYes
    ARP inspectionYes
    Web-based managementYes
    Quality of Service (QoS) supportYes
    Switch layerL2
    Switch typeManaged

    Ports & interfaces

    SFP+ module slots quantity2
    Combo SFP ports quantity2
    Basic switching RJ-45 Ethernet ports type10G Ethernet (100/1000/10000)
    Basic switching RJ-45 Ethernet ports quantity12
    Show all 72 specificationsShow fewer specifications

    Network

    Virtual LAN featuresVoice VLAN, MAC address-based VLAN, Port-based VLAN
    VLAN supportYes
    Flow control supportYes
    Auto MDI/MDI-XYes
    Broadcast storm controlYes
    Spanning tree protocolYes
    Head-of-line (HOL) blockingYes
    Port mirroringYes
    Copper ethernet cabling technology10GBASE-T, 100BASE-TX, 1000BASE-T
    10G supportYes
    Networking standardsIEEE 802.1D, IEEE 802.1Q, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3ae, IEEE 802.3an, IEEE 802.3az, IEEE 802.3p, IEEE 802.3u, IEEE 802.3z

    Optical fiber

    Fiber ethernet cabling technology1000BASE-X

    Data transmission

    Jumbo frames16000
    Jumbo frames supportYes
    Store-and-forwardYes
    Forwarding rate238.08 Mpps
    Switching capacity320 Gbit/s
    MAC address table16000 entries

    Security

    Security algorithms802.1x RADIUS, SNMP, SSL/TLS
    IP-MAC-Port bindingYes
    IGMP snoopingYes
    Access Control List (ACL) rules256
    Access Control List (ACL)Yes
    DHCP featuresDHCP server, DHCP client

    Multicast features

    Multicast Listener Discovery (MLD) snoopingMLD v
    Multicast supportYes

    Protocols

    Supported network protocolsIPv4, IPv6

    Design

    SafetycUL, CB, CE, CCC, BSMI
    LED indicatorsActivity, Link, Power, Speed
    Product colourBlack
    Rack mountingYes

    Performance

    Built-in processorYes

    Power

    Power consumption (max)90.81 W
    AC input frequency50 - 60 Hz
    AC input voltage120 - 230 V

    Power over Ethernet (PoE)

    Power over Ethernet (PoE)No

    Operational conditions

    Storage relative humidity (H-H)0 - 95%
    Operating relative humidity (H-H)0 - 95%
    Storage temperature (T-T)-40 - 70 °C
    Operating temperature (T-T)-5 - 50 °C

    Weight & dimensions

    Weight3.15 kg
    Height44 mm
    Depth210 mm
    Width440 mm

    Technical details

    Shipping (inner) case height38.3 cm
    Shipping (inner) case width31.4 cm
    Shipping (inner) case length56.2 cm
    Shipping (inner) case net weight13.6 kg
    Products per shipping (inner) case3 pc(s)
    Pallet gross weight (air)281.1 kg
    Master (outer) cases per pallet (air)18 pc(s)
    Products per pallet (air)54 pc(s)
    Pallet gross length110 cm
    Pallet gross width120 cm
    Pallet height (air)128.4 cm
    Pallet gross weight (sea)456 kg
    Master (outer) cases per pallet (sea)30 pc(s)
    Products per pallet (sea)90 pc(s)
    Pallet height (sea)2.05 m
    Shipping (inner) case gross weight14.5 kg

    Certificates

    CertificationCE, FCC, C-Ticket, VCCI, BSMI, CCC

    Manuals & downloads

    • Mmo_33229431_1476367307_5886_2700.pdf (PDF)
    • Mmo_33229431_1476367332_9933_4275.pdf (PDF)

    Customer reviews

    Delivery & returns

    Delivery

    • FREE standard delivery on orders over £50, otherwise £4.95 (3–5 working days).
    • Express delivery £9.99 (1–3 working days) on selected products, UK mainland.
    • PlayStation and Arozzi products use a 5–7 working-day service.
    • Orders are processed within 24 hours, Monday to Friday excluding bank holidays. All deliveries must be signed for.

    Returns

    • Changed your mind? Tell us within 14 days of receiving your item, then return it within a further 14 days, unused and in its original packaging. A minimum £9.99 collection fee applies.
    • Faulty or damaged on arrival? Contact us within 48 hours of delivery.
    • Custom-built PCs can only be returned if faulty. Opened headphones, earphones and AirPods can't be returned for hygiene reasons.

    Full delivery information · Full returns policy

    Similar products

    Goes with this

    D-Link 12-port 10GBASE-T, 2-port SFP+ and 2-port 10GBASE-T/SFP+ Multi-Gigabit Smart Managed Switch £1,631.99

    Information

    • About us
    • Contact us
    • Our Reviews
    • Shipping Policy
    • Terms & Conditions
    • Privacy & Cookie Policy
    • Fraud Prevention & Security
    • Returns & Refunds
    • Money Wellness (Debt Advice)
    • For Business

    Support

    • Delivery Information
    • Manufacturer Warranty
    • Price Match Promise
    • Snap Finance
    • Klarna
    • ClearPay
    • Careers
    • Complaints
    • Vulnerable Customer Policy & TCF
    • Ink & Toner Finder
    • Buying Guides
    • Gaming PC Gift Finder
    • Gaming PC Guide for Parents

    My Account

    • Sign In
    • Register
    • Track your order
    • Returns
    • Shop By Brand
    • Affiliate Program
    • FAQ

    Contact Us

    Head Office:
    71-75 Shelton Street, Covent Garden, London, United Kingdom, WC2H 9JQ

    Email: hello@backtotheoffice.co.uk

    Track your order

    Follow Us:

    Opens external website in a new window. Opens external website in a new window. Opens external website in a new window.
    Visa Mastercard American Express PayPal Clearpay
    Klarna Google Pay Apple Pay Snap Finance Float

    Snap Finance: Back to the Office is an Introducer Appointed Representative of Snap Finance Limited which is authorised and regulated by the Financial Conduct Authority (Firm reference number 741813). Snap Finance Limited act as the lender.

    Pay later with Klarna. Borrowing more than you can afford or paying late may negatively impact your financial status and ability to obtain credit. Subject to status. Ts&Cs and late fees apply. Klarna.com/uk/terms-and-conditions

    Clearpay: Clearpay credit subject to status. Ensure you can make repayments on time. You must be 18+ and a permanent UK resident (excl Channel Islands). Clearpay charges a £6 late fee for each late instalment and a further £6 if it’s still unpaid 7 days later. Late fees are capped at £6 for orders under £24 and the lower of £24 or 25% of the order value for orders over £24. Missed payments may affect your future access to credit and your details may be passed onto a debt collection agency working on Clearpay's behalf. T&Cs apply Clearpay.co.uk/terms

    Float: Float charges no interest or fees on your instalment plan. Your credit card issuer’s standard terms and conditions, including interest on outstanding balances, will still apply. Please make sure you can comfortably afford each monthly instalment. Float is the trading name of Float Technologies Limited, registered in England and Wales (Company Number: 16558482). Float is not authorised and regulated by the Financial Conduct Authority.

    © 2026 Back to the Office.

    Your basket

      Your basket is empty

      Start shopping

        Subtotal

        Delivery and any discount codes are calculated at checkout.

        Checkout securely
        View basket