Menu
  • Sign in
  • Checkout
Back to the Office

Sign in Checkout
Home Yealink SIP-T58W PRO IP phone Grey LCD Wi-Fi
Yealink SIP-T58W PRO IP phone Grey LCD Wi-Fi
Yealink SIP-T58W PRO IP phone Grey LCD Wi-Fi
Yealink SIP-T58W PRO IP phone Grey LCD Wi-Fi

Yealink SIP-T58W PRO IP phone Grey LCD Wi-Fi

Yealink · MPN: 1301113
Sale!
from £307.99
/per
inc. VAT
Spread the cost with Klarna, Clearpay, PayPal, Float or SnapFrom 3 interest-free payments of £102.66 See options

Credit subject to status. 18+, UK residents only. See each provider for terms.

Key specs

  • Display diagonal17.8 cm (7")
  • Display resolution1024 x 600 pixels
  • Wi-Fi standards802.11a, 802.11b, 802.11g, Wi-Fi 4 (802.11n)
All specifications

Out of stock

FREE delivery

Express £9.99

 
 

  • 14-day returns Details
  • UK manufacturer warranty Details
  • Price Match Promise Details
  • Rated 4.9/5 by customers on Trustpilot & Feefo Read reviews

Available now

    OverviewSpecificationsManuals & downloadsReviews Delivery & returns

    Overview

    Free from Cord Constraint, Free from Distracting Noise

    Adopting the innovative Bluetooth handset, Yealink T58W Pro pervades wireless communication by allowing the user to move around freely and conveniently.

    The professional hardware and the cutting-edge acoustic algorithm of Yealink makes the T58W Series an expert at eliminating noise and keeping every conversation clear and focus.

    Take Smart Business Phone to the Next Level
    Boost by the upgraded chipsets, the T58W Series comes with enhanced system performance with fast response and reinforced processing capacity. The adoption of Android 9.0 OS also improves the data encryption, authority management, response speed and integratability to meet requirements of modern business and future sustainability.

    Enterprise-level Security, Provision and Management
    Taking data security as one of the most significant concerns, the new set of phones adopt Arm TrustZone technology to safeguard various ARM-based data and applications.

    By supporting Yealink/Unify Square Device Management Platform, the management, provision and update of the T58W Series can be implemented in a streamlined and simplified manner.

    Specifications

    Design

    Product typeIP Phone
    Handset typeWireless handset
    Product colourGrey
    Wall mountableYes

    Performance

    Dual-Tone Multi-Frequency (DTMF) modesIn-band, Out-of band, SIP info
    Hearing aid compatibilityYes
    Show all 62 specificationsShow fewer specifications

    Phone features

    Answering machineYes
    Anonymous call rejectionYes
    Anonymous callYes
    Phonebook capacity1000 entries
    IntercomYes
    Call returnYes
    Call parkYes
    Message-waiting indicator (MWI)Yes
    Full duplexYes
    Call transferYes
    Call pick upYes
    Do not disturb functionYes
    RedialingYes
    Conference callYes
    Call forwardingYes
    Call holdYes
    Speed diallingYes
    Call waitingYes
    Caller IDYes

    Management features

    Integrated voicemailYes
    Number of function keys7
    Keypad number of keys27

    Display

    DisplayLCD
    Display diagonal17.8 cm (7")
    Display resolution1024 x 600 pixels
    TouchscreenYes
    Touchscreen typeCapacitive

    Audio

    SpeakerphoneYes
    Microphone muteYes
    Automatic gain controlYes
    Noise reductionYes
    Packet loss concealment (PLC)Yes
    Comfort noise generation (CNG)Yes
    Adaptive jitter buffersYes
    Voice activity detectionYes
    Voice codecsG.711a, G.722, G.723.1, G.726, G.729, G.729A, G.729B, iLBC

    Video

    Video resolutions1280 x 720 pixels
    Video codecsH.264 High Profile, H.264, VP8

    Network

    Ethernet LANYes
    Ethernet LAN data rates1000 Mbit/s
    Ethernet LAN interface typeGigabit Ethernet
    Wi-Fi standards802.11a, 802.11b, 802.11g, Wi-Fi 4 (802.11n)
    Wi-FiYes
    BluetoothYes
    Bluetooth version4.2
    Networking standardsIEEE 802.11a, IEEE 802.11b, IEEE 802.11g, IEEE 802.11n, IEEE 802.1x, IEEE 802.3af
    Supported network protocolsIPv4/IPv6, SIP v1 (RFC2543), v2 (RFC3261), UDP/TCP/DNS-SRV (RFC 3263)
    Quality of Service (QoS) supportYes
    Security algorithms256-bit AES, HTTPS, TLS, WPA2, WPA3

    Ports & interfaces

    USB 2.0 ports quantity2
    RJ-9 ports quantity2
    Ethernet LAN (RJ-45) ports2

    Power

    Power over Ethernet (PoE)Yes

    Operational conditions

    Operating relative humidity (H-H)10 - 95%
    Operating temperature (T-T)0 - 40 °C

    Packaging content

    Number of handles included1 pc(s)

    Manuals & downloads

    • Manual pdf (PDF)

    Customer reviews

    Delivery & returns

    Delivery

    • FREE standard delivery on orders over £50, otherwise £4.95 (3–5 working days).
    • Express delivery £9.99 (1–3 working days) on selected products, UK mainland.
    • PlayStation and Arozzi products use a 5–7 working-day service.
    • Orders are processed within 24 hours, Monday to Friday excluding bank holidays. All deliveries must be signed for.

    Returns

    • Changed your mind? Tell us within 14 days of receiving your item, then return it within a further 14 days, unused and in its original packaging. A minimum £9.99 collection fee applies.
    • Faulty or damaged on arrival? Contact us within 48 hours of delivery.
    • Custom-built PCs can only be returned if faulty. Opened headphones, earphones and AirPods can't be returned for hygiene reasons.

    Full delivery information · Full returns policy

    Similar products

    Goes with this

    Yealink SIP-T58W PRO IP phone Grey LCD Wi-Fi £307.99

    Information

    • About us
    • Contact us
    • Our Reviews
    • Shipping Policy
    • Terms & Conditions
    • Privacy & Cookie Policy
    • Fraud Prevention & Security
    • Returns & Refunds
    • Money Wellness (Debt Advice)
    • For Business

    Support

    • Delivery Information
    • Manufacturer Warranty
    • Price Match Promise
    • Snap Finance
    • Klarna
    • ClearPay
    • Careers
    • Complaints
    • Vulnerable Customer Policy & TCF
    • Ink & Toner Finder
    • Buying Guides
    • Gaming PC Gift Finder
    • Gaming PC Guide for Parents

    My Account

    • Sign In
    • Register
    • Track your order
    • Returns
    • Shop By Brand
    • Affiliate Program
    • FAQ

    Contact Us

    Head Office:
    71-75 Shelton Street, Covent Garden, London, United Kingdom, WC2H 9JQ

    Email: hello@backtotheoffice.co.uk

    Phone: 020 8064 1353

    Follow Us:

    Opens external website in a new window. Opens external website in a new window. Opens external website in a new window.
    Visa Mastercard American Express PayPal Clearpay
    Klarna Google Pay Apple Pay Snap Finance Float

    Snap Finance: Back to the Office is an Introducer Appointed Representative of Snap Finance Limited which is authorised and regulated by the Financial Conduct Authority (Firm reference number 741813). Snap Finance Limited act as the lender.

    Pay later with Klarna. Borrowing more than you can afford or paying late may negatively impact your financial status and ability to obtain credit. Subject to status. Ts&Cs and late fees apply. Klarna.com/uk/terms-and-conditions

    Clearpay: Clearpay credit subject to status. Ensure you can make repayments on time. You must be 18+ and a permanent UK resident (excl Channel Islands). Clearpay charges a £6 late fee for each late instalment and a further £6 if it’s still unpaid 7 days later. Late fees are capped at £6 for orders under £24 and the lower of £24 or 25% of the order value for orders over £24. Missed payments may affect your future access to credit and your details may be passed onto a debt collection agency working on Clearpay's behalf. T&Cs apply Clearpay.co.uk/terms

    Float: Float charges no interest or fees on your instalment plan. Your credit card issuer’s standard terms and conditions, including interest on outstanding balances, will still apply. Please make sure you can comfortably afford each monthly instalment. Float is the trading name of Float Technologies Limited, registered in England and Wales (Company Number: 16558482). Float is not authorised and regulated by the Financial Conduct Authority.

    © 2026 Back to the Office.